现在的位置: 首页 > 综合 > 正文

ZOJ3777—Problem Arrangement

2019年02月13日 ⁄ 综合 ⁄ 共 3090字 ⁄ 字号 评论关闭

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it’s not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of “interesting value” to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.
Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).
Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output “No solution” instead.
Sample Input

2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4

Sample Output

3/1
No solution

Author: DAI, Longao
Source: The 11th Zhejiang Provincial Collegiate Programming Contest

dp[i][j][k]表示到第i行,状态为j,和大于等于k的方案数

/*************************************************************************
    > File Name: B.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年03月07日 星期六 14时57分38秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

LL dp[2][(1 << 12) + 5][505];
int p[13][13];
int num[(1 << 12) + 5];
LL fum[13];

LL gcd (LL a, LL b)
{
    return b ? gcd (b, a % b) : a;
}

int main ()
{
    int t;
    scanf("%d", &t);
    fum[0] = 1;
    for (int i = 1; i <= 12; ++i)
    {
        fum[i] = fum[i - 1] * i;
    }
    for (int i = 0; i < (1 << 12); ++i)
    {
        num[i] = 0;
        for (int j = 0; j <= 12; ++j)
        {
            if (i & (1 << j))
            {
                ++num[i];
            }
        }
    }
    while (t--)
    {
        int n, m;
        scanf("%d%d", &n, &m);
        memset (dp, 0, sizeof(dp));
        dp[0][0][0] = 1;
        for (int i = 1; i <= n; ++i)
        {
            for (int j = 1; j <= n; ++j)
            {
                scanf("%d", &p[i][j]);
            }
        }
        for (int i = 1; i <= n; ++i)
        {
            for (int j = 0; j < (1 << n); ++j)
            {
                if (num[j] != i - 1)
                {
                    continue;
                }
                for (int k = 1; k <= n; ++k)
                {
                    if (j & (1 << (k - 1)))
                    {
                        continue;
                    }
                    for (int sum = 0; sum <= m; ++sum)
                    {
                        int nowsum = sum + p[i][k];
                        if (sum + p[i][k] >= m)
                        {
                            nowsum = m;
                        }
                        dp[i % 2][j | (1 << (k - 1))][nowsum] += dp[1 - i % 2][j][sum];
                    }
                }
            }
        }
        if (dp[n % 2][(1 << n) - 1][m] == 0)
        {
            printf("No solution\n");
            continue;
        }
        LL G = gcd (dp[n % 2][(1 << n) - 1][m], fum[n]);
        printf("%lld/%lld\n", fum[n] / G, dp[n % 2][(1 << n) - 1][m] / G);
    }
    return 0;
}

抱歉!评论已关闭.