现在的位置: 首页 > 综合 > 正文

hdu4283—You Are the One(区间dp)

2019年02月14日 ⁄ 综合 ⁄ 共 2582字 ⁄ 字号 评论关闭

Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?

Input
  The first line contains a single integer T, the number of test cases. For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)

Output
  For each test case, output the least summary of unhappiness .

Sample Input

2    5 1 2 3 4 5 5 5 4 3 2 2

Sample Output

Case #1: 20 Case #2: 24

Source
2012 ACM/ICPC Asia Regional Tianjin Online

Recommend
liuyiding | We have carefully selected several similar problems for you: 4267 4268 4269 4270 4271

区间dp,设dp[i][j] 表示考虑第i个人到第j个人时的最小代价
那么第i个人可以是第1个上的,第2个上的,….第j-i+1个上的
如果设他在第k个上,那么就要把(i,i + k - 1)这k个人放到栈里面,这样第i个人才会在第k个位置上上场,那么(i + k , j)这些人就是在k之后上场了
于是可以把区间分为dp[i + 1][i + k - 1], dp[i + k][j],然后处理下决策就行了

/*************************************************************************
    > File Name: hdu4283.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年02月23日 星期一 14时45分54秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int N = 110;
int dp[N][N];
int arr[N];
int sum[N];

int main ()
{
    int t;
    scanf("%d", &t);
    int icase = 1;
    while (t--)
    {
        int n;
        scanf("%d", &n);
        sum[0] = 0;
        for (int i = 1; i <= n; ++i)
        {
            scanf("%d", &arr[i]);
            sum[i] = sum[i - 1] + arr[i];
        }
        memset (dp, 0, sizeof(dp));
        for (int i = 1; i <= n; ++i)
        {
            for (int j = i; j <= n; ++j)
            {
                dp[i][j] = inf;
            }
        }
        for (int i = n; i >= 1; --i)
        {
            for (int j = i; j <= n; ++j)
            {
                for (int k = 1; k <= j - i + 1; ++k)
                {
                    dp[i][j] = min (dp[i + 1][i + k - 1] + dp[i + k][j] + arr[i] * (k - 1) + (sum[j] - sum[i + k - 1]) * k, dp[i][j]);
                }
            }
        }
        printf("Case #%d: %d\n", icase++, dp[1][n]);
    }
    return 0;
}

抱歉!评论已关闭.