现在的位置: 首页 > 综合 > 正文

POJ1860—Currency Exchange

2019年02月15日 ⁄ 综合 ⁄ 共 3651字 ⁄ 字号 评论关闭
Currency Exchange
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 21122   Accepted: 7572

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing
in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected
in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain
6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

spfa找正环

/*************************************************************************
    > File Name: poj1860.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年01月30日 星期五 18时45分23秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;
const int N = 110;
double dist[N];

int head[N], tot;
int vis[N];
struct node
{
	double r, c;
	int next;
	int to;
}edge[N * N];

void addedge (int from, int to, double r, double c)
{
	edge[tot].r = r;
	edge[tot].c = c;
	edge[tot].to = to;
	edge[tot].next = head[from];
	head[from] = tot++;
}

void spfa (int s, double x, int n)
{
	memset (vis, 0, sizeof(vis));
	dist[s] = x;
	queue <int> qu;
	vis[s] = 1;
	while (!qu.empty())
	{
		qu.pop();
	}
	qu.push (s);
	bool flag = false;
	while (!qu.empty())
	{
		int u = qu.front();
		qu.pop();
		for (int i = head[u]; ~i; i = edge[i].next)
		{
			int v = edge[i].to;
			if (dist[v] < (dist[u] - edge[i].c) * edge[i].r)
			{
				dist[v] = (dist[u] - edge[i].c) * edge[i].r;
				qu.push (v);
				vis[v]++;
				if (vis[v] > n)
				{
					flag = true;
					break;
				}
			}
		}
		if (flag)
		{
			break;
		}
	}
	if (flag)
	{
		printf("YES\n");
	}
	else
	{
		printf("NO\n");
	}
}

int main ()
{
	int n, m, s;
	double x;
	while(~scanf("%d%d%d%lf", &n, &m, &s, &x))
	{
		for (int i = 1; i <= n; ++i)
		{
			dist[i] = 0;
		}
		memset (head, -1, sizeof(head));
		tot = 0;
		int u, v;
		double r, c;
		for (int i = 1; i <= m; ++i)
		{
			scanf("%d%d%lf%lf", &u, &v, &r, &c);
			addedge (u, v, r, c);
			scanf("%lf%lf", &r, &c);
			addedge (v, u, r, c);
		}
		spfa (s, x, n);
	}
	return 0;
}

抱歉!评论已关闭.