现在的位置: 首页 > 综合 > 正文

POJ1502——MPI Maelstrom

2019年02月15日 ⁄ 综合 ⁄ 共 3441字 ⁄ 字号 评论关闭

Description

BIT has
recently taken delivery of their new supercomputer, a 32 processor
Apollo Odyssey distributed shared memory machine with a hierarchical
communication subsystem. Valentine McKee's research advisor, Jack
Swigert, has asked her to benchmark the new system.

``Since the Apollo is a distributed shared memory machine, memory
access and communication times are not uniform,'' Valentine told
Swigert. ``Communication is fast between processors that share the same
memory subsystem, but it is slower between processors that are not on
the same subsystem. Communication between the Apollo and machines in our
lab is slower yet.''

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked.

``Not so well,'' Valentine replied. ``To do a broadcast of a message
from one processor to all the other n-1 processors, they just do a
sequence of n-1 sends. That really serializes things and kills the
performance.''

``Is there anything you can do to fix that?''

``Yes,'' smiled Valentine. ``There is. Once the first processor has
sent the message to another, those two can then send messages to two
other hosts at the same time. Then there will be four hosts that can
send, and so on.''

``Ah, so you can do the broadcast as a binary tree!''

``Not really a binary tree -- there are some particular features of
our network that we should exploit. The interface cards we have allow
each processor to simultaneously send messages to any number of the
other processors connected to it. However, the messages don't
necessarily arrive at the destinations at the same time -- there is a
communication cost involved. In general, we need to take into account
the communication costs for each link in our network topologies and plan
accordingly to minimize the total time required to do a broadcast.''

Input

The
input will describe the topology of a network connecting n processors.
The first line of the input will be n, the number of processors, such
that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency
matrix is square and of size n x n. Each of its entries will be either
an integer or the character x. The value of A(i,j) indicates the expense
of sending a message directly from node i to node j. A value of x for
A(i,j) indicates that a message cannot be sent directly from node i to
node j.

Note that for a node to send a message to itself does not require
network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you
may assume that the network is undirected (messages can go in either
direction with equal overhead), so that A(i,j) = A(j,i). Thus only the
entries on the (strictly) lower triangular portion of A will be
supplied.

The input to your program will be the lower triangular section of A.
That is, the second line of input will contain one entry, A(2,1). The
next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your
program should output the minimum communication time required to
broadcast a message from the first processor to all the other
processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

Source

水题,以前没去学floyd算法,今天看了下,很简单。其实利用了dp 的思想,从i-j,无非是直接从i-j,或者中间有其他节点k,所以dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]),代码实现也是三个for,O(N^3),但是要注意三个for 的循环顺序,如果把中间节点k的循环放在最里面的话,会导致dp[i][k],dp[k][j],也就是i-k,k-j的最短路并没有计算,然后就拿来用了,就会出问题,这样以后dp[i][j]实际不会再更新。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define inf 0x3f3f3f

using namespace std;

int dp[110][110];

int main()
{
int n;
while(~scanf("%d",&n))
{
char num[4];
memset(dp,inf,sizeof(dp));
for(int i=1;i<=n;i++)
dp[i][i]=0;
for(int i=2;i<=n;i++)
for(int j=1;j<i;j++)
{
scanf("%s",num);
if(num[0]=='x')
dp[i][j]=dp[j][i]=inf;
else
{
int ans=0;
int len=strlen(num);
for(int k=0;k<len;k++)
ans=ans*10+(num[k]-'0');
dp[i][j]=dp[j][i]=ans;
}
}
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(dp[i][k]+dp[k][j]<dp[i][j])
dp[i][j]=dp[i][k]+dp[k][j];
int ans=-inf;
for(int i=1;i<=n;i++)
ans=max(ans,dp[1][i]);
printf("%d\n",ans);
}
return 0;
}

抱歉!评论已关闭.