现在的位置: 首页 > 综合 > 正文

POJ1679——The Unique MST

2019年02月15日 ⁄ 综合 ⁄ 共 2305字 ⁄ 字号 评论关闭

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph
G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'),
with the following properties:

1. V' = V.

2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted,
connected, undirected graph G = (V, E). The minimum spanning tree T =
(V, E') of G is the spanning tree that has the smallest total cost. The
total cost of T means the sum of the weights on all the edges in E'.

Input

The
first line contains a single integer t (1 <= t <= 20), the number
of test cases. Each case represents a graph. It begins with a line
containing two integers n and m (1 <= n <= 100), the number of
nodes and edges. Each of the following m lines contains a triple (xi,
yi, wi), indicating that xi and yi are connected by an edge with weight =
wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

POJ Monthly--2004.06.27 srbga@POJ

    问最小生成树是不是唯一的,那么我们可以求次小生成树,如果次小生成树和权值一样的话,那么最小生成树就是不唯一的,否则就是唯一的。
    求次小生成树的方法就是先求出最小生成树,然后枚举删去一条边,加入一条原本不在最小生成树里的边,求得最小值。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>

using namespace std;

const int maxn=105;

int father[maxn];

struct node
{
int from,to;
int weight;
}edge[maxn*maxn];

bool used[maxn][maxn];

void unit(int n)
{
for(int i=0;i<=n;i++)
father[i]=i;
}

int find(int x)
{
if(x!=father[x])
father[x]=find(father[x]);
return father[x];
}

int cmp(node a,node b)
{
return a.weight < b.weight;
}

int kruskal(int n,int m)
{
unit(n);
sort(edge,edge+m,cmp);
memset(used,0,sizeof(used));
int sum=0;
int cnt=0;
for(int i=0;i<m;i++)
{
int a=find(edge[i].from);
int b=find(edge[i].to);
if(a!=b)
{
father[a]=b;
used[edge[i].from][edge[i].to]=1;
used[edge[i].to][edge[i].from]=1;
sum+=edge[i].weight;
cnt++;
if(cnt==n-1)
break;
}
}
return sum;
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=0;i<m;i++)
scanf("%d%d%d",&edge[i].from,&edge[i].to,&edge[i].weight);
int sum=kruskal(n,m),ans=0x3f3f3f3f;
for(int i=0;i<m;i++)
{
if(!used[edge[i].from][edge[i].to] && !used[edge[i].to][edge[i].from])
{
for(int j=0;j<m;j++)
{
if(used[edge[j].from][edge[j].to] || used[edge[j].to][edge[j].from])
ans=min(ans,sum-edge[j].weight+edge[i].weight);
}
}
}
if(ans==sum)
printf("Not Unique!\n");
else
printf("%d\n",sum);
}
return 0;
}


抱歉!评论已关闭.