现在的位置: 首页 > 综合 > 正文

POJ1862——Stripies

2019年02月15日 ⁄ 综合 ⁄ 共 1827字 ⁄ 字号 评论关闭
Stripies
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 12366   Accepted: 5866

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent).
The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists
enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals
to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

Northeastern Europe 2001, Northern Subregion

贪心题,每次都取大的两个计算

简单证明下这种策略的正确性

左边大于等于1,右边小于等于1,由分析法可知等式一定成立

而且此策略下得到的新的数一定大于已存在的其他数

#include <map>  
#include <set>  
#include <list>  
#include <stack>  
#include <vector>  
#include <queue>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  

using namespace std;

int a[105];

int cmp(int a, int b)
{
	return a > b;
}

int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		for (int i = 0; i < n; ++i)
		{
			scanf("%d", &a[i]);
		}
		sort(a, a + n, cmp);
		double ans = (double)a[0];
		for (int i = 1; i < n; ++i)
		{
			ans = 2 * sqrt (a[i] * ans);
		}
		printf("%.3f\n", ans);
	}
	return 0;
}

抱歉!评论已关闭.