现在的位置: 首页 > 综合 > 正文

hdu1596——find the safest road

2019年02月15日 ⁄ 综合 ⁄ 共 1866字 ⁄ 字号 评论关闭

find the safest road

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7275    Accepted Submission(s): 2580

Problem Description
XX星球有很多城市,每个城市之间有一条或多条飞行通道,但是并不是所有的路都是很安全的,每一条路有一个安全系数s,s是在 0 和 1 间的实数(包括0,1),一条从u 到 v 的通道P 的安全度为Safe(P) = s(e1)*s(e2)…*s(ek) e1,e2,ek是P 上的边 ,现在8600 想出去旅游,面对这这么多的路,他想找一条最安全的路。但是8600 的数学不好,想请你帮忙 ^_^
 

Input
输入包括多个测试实例,每个实例包括:
第一行:n。n表示城市的个数n<=1000;
接着是一个n*n的矩阵表示两个城市之间的安全系数,(0可以理解为那两个城市之间没有直接的通道)
接着是Q个8600要旅游的路线,每行有两个数字,表示8600所在的城市和要去的城市
 

Output
如果86无法达到他的目的地,输出"What a pity!",
其他的输出这两个城市之间的最安全道路的安全系数,保留三位小数。
 

Sample Input
3 1 0.5 0.5 0.5 1 0.4 0.5 0.4 1 3 1 2 2 3 1 3
 

Sample Output
0.500 0.400 0.500
 

Author
#include <set>
#include <map>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 1010;

struct node
{
	double weight;
	int next;
	int to;
}edge[N * N];

double dist[N];
int head[N];
int tot, n;

void addedge(int from, int to, double weight)
{
	edge[tot].weight = weight;
	edge[tot].to = to;
	edge[tot].next = head[from];
	head[from] = tot++;
}

void spfa(int v0)
{
	for (int i = 1; i <= n; i++)
	{
		dist[i] = 0.000;
	}
	dist[v0] = 1.000;
	queue <int> qu;
	while ( !qu.empty() )
	{
		qu.pop();
	}
	qu.push(v0);
	while ( !qu.empty() )
	{
		int u = qu.front();
		qu.pop();
		for (int i = head[u]; ~i; i = edge[i].next)
		{
			int v = edge[i].to;
//			printf("%.3f %.3f\n", dist[v], dist[u] * edge[i].weight);
			if (dist[v] < dist[u] * edge[i].weight)
			{
				dist[v] = dist[u] * edge[i].weight;
				qu.push(v);
			}
		}
	}
}

int main()
{
	while (~scanf("%d", &n))
	{
		double w;
		int u, v;
		memset (head, -1, sizeof(head) );
		tot = 0;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				scanf("%lf", &w);
				addedge(i, j, w);
			}
		}
		int m;
		scanf("%d", &m);
		while (m--)
		{
			scanf("%d%d", &u, &v);
			spfa(u);
			if (dist[v] != 0)
			{
				printf("%.3lf\n", dist[v]);
				continue;
			}
			printf("What a pity!\n");
		}
	}
	return 0;
}

ailyanlu
 

Source
 

Recommend
8600   |   We have carefully selected several similar problems for you:  1217 1598 1142 1690 2544 
 

最短路变形, 只要把限制条件改一下就可以了

抱歉!评论已关闭.