现在的位置: 首页 > 综合 > 正文

ACdream1236——Burning Bridges

2019年02月15日 ⁄ 综合 ⁄ 共 2791字 ⁄ 字号 评论关闭

Burning Bridges

Special JudgeTime Limit: 10000/5000MS (Java/Others)Memory Limit: 128000/64000KB (Java/Others)

Problem Description

      Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridges are very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designed in such a way that one can get from any
island to any other one.

      But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armies of the great warrior Jordan and he has decided to burn all the bridges that connected the islands. This was a very cruel decision, but the wizards of Jordan
have advised him no to do so, because after that his own armies would not be able to get from one island to another. So Jordan decided to burn as many bridges as possible so that is was still possible for his armies to get from any island to any other one.

      Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannot learn that, because the list of bridges to be burned is kept in great secret. However, one old man said that you can help them to find the set of bridges
that certainly will not be burned.

      So they came to you and asked for help. Can you do that?

Input

      The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdom respectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numbers each and describe
bridges. Note that there can be several bridges between a pair of islands.

Output

      On the first line of the output file print K — the number of bridges that will certainly not be burned.
      On the second line print K integers — the numbers of these bridges. Bridges are numbered starting from one, as they are given in the input file.

Sample Input

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

Sample Output

2
3 7

Source

Andrew Stankevich Contest 4

Manager

mathlover

求出所有的桥就行

#include<map>  
#include<set>  
#include<list>  
#include<stack>  
#include<vector>  
#include<queue>  
#include<cmath>  
#include<cstdio>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
  
using namespace std; 

const int N = 10010;
const int M = 100010;

struct Node
{
	int next;
	int to;
	int d;
}edge[M << 2];

int head[N];
int DFN[N];
int low[N];
bool instack[N];
int bridge[M << 2];
int tot, cnt, res, n, m;

void addedge(int from, int to, int d)
{
	edge[tot].to = to;
	edge[tot].d = d;
	edge[tot].next = head[from];
	head[from] = tot++;
}

void tarjan(int u, int fa)
{
	DFN[u] = low[u] = ++cnt;
	instack[u] = 1;
	for (int i = head[u]; i != -1; i = edge[i].next)
	{
		int v = edge[i].to;
		if(edge[i].d == fa)
		{
			continue;
		}
		if (!DFN[v])
		{
			tarjan(v, edge[i].d);
			low[u] = min(low[u], low[v]);
			if(low[v] > DFN[u])
			{
				bridge[res++] = edge[i].d;
			}
		}
		else if(instack[v])
		{
			low[u] = min(low[u], DFN[v]);
		}
	}
}

int main()
{
	while (~scanf("%d%d", &n, &m))
	{
		memset ( head, -1, sizeof(head) );
		memset ( instack, 0, sizeof(instack) );
		memset (DFN, 0, sizeof(DFN) );
		cnt = tot = res = 0;
		int u, v;
		for (int i = 1; i <= m; i++)
		{
			scanf("%d%d", &u, &v);
			addedge(u, v, i);
			addedge(v, u, i);
		}
		for (int i = 1; i <= n; i++)
		{
			if (DFN[i] == 0)
			{
				tarjan(i, -1);
			}
		}
		sort(bridge, bridge + res);
		printf("%d\n", res);
		if (res == 0)
		{
			continue;
		}
		printf("%d", bridge[0]);
		for (int i = 1; i < res; i++)
		{
			printf(" %d", bridge[i]);
		}
		printf("\n");
	}
	return 0;
}

抱歉!评论已关闭.