现在的位置: 首页 > 综合 > 正文

POJ3114——Countries in War

2019年02月16日 ⁄ 综合 ⁄ 共 5289字 ⁄ 字号 评论关闭
Countries in War
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2603   Accepted: 776

Description

In the year 2050, after different attempts of the UN to maintain peace in the world, the third world war broke out. The importance of industrial, commercial and military secrets obliges all the countries to use extremely sophisticated espionage services,
so that each city in the world has at least one spy of each country. These spies need to communicate with other spies, informers as well as their headquarters during their actions. Unluckily there doesn’t exist a secure way for a spy to communicate during
the war period, therefore the messages are always sent in code so that only the addressee is able to read the message and understand its meaning.

The spies use the only service that functions during the war period, the post. Each city has a postal agency where the letters are sent. The letters can be sent directly to their destination or to other postal agencies, until the letter arrives at the postal
agency of the destination city, if possible.

The postal agency in city A can send a printed letter to the postal agency in city B if there is an agreement on sending letters, which determines the time, in hours, that a letter takes to reach city B from city A (and not necessarily the opposite). If
there is no agreement between the agencies A and B, the agency A can try to send the letter to any agency so that the letter can reach its destination as early as possible

Some agencies are connected with electronic communication media, such as satellites and optical fibers. Before the war, these connections could reach all the agencies, making that a letter could be sent instantly. But during the period of hostilities every
country starts to control electronic communication and an agency can only send a letter to another agency by electronic media (or instantly) if they are in the same country. Two agencies, A and B, are in the same country if a printed letter sent from any one
of the agencies can be delivered to the other one.

The espionage service of your country has managed to obtain the content of all the agreements on sending messages existing in the world and desires to find out the minimum time to send a letter between different pairs of cities. Are you capable of helping
them?

Input

The input contains several test cases. The first line of each test case contains two integer separated by a space,
N (1 ≤ N ≤ 500) and E (0 ≤ EN2), indicating the numbers of cities (numbered from 1 to
N) and of agreements on sending messages, respectively. Following them, then,
E lines, each containing three integers separated by spaces, X,
Y and H (1 ≤ X, YN, 1 ≤ H ≤ 1000), indicating that there exist an agreement to send a printed letter from city
X to city Y, and that such a letter will be delivered in H hours.

After that, there will be a line with an integer K (0 ≤ K ≤ 100), the number of queries. Finally, there will be
K lines, each representing a query and containing two integers separated by a space,
O and D (1 ≤ O, DN). You must determine the minimum time to send a letter from city
O to city D.

The end of the input is indicated by N = 0.

Output

For each test case your program should produce K lines of output. The
I-th line should contain an integer M, the minimum time, in hours, to send a letter in the
I-th query. If there aren’t communication media between the cities of the query, you should print “Nao e possivel entregar a carta” (“It’s impossible to deliver the letter”).

Print a blank line after each test case.

Sample Input

4 5
1 2 5
2 1 10
3 4 8
4 3 7
2 3 6
5
1 2
1 3
1 4
4 3
4 1
3 3
1 2 10
2 3 1
3 2 1
3
1 3
3 1
3 2
0 0

Sample Output

0
6
6
0
Nao e possivel entregar a carta

10
Nao e possivel entregar a carta
0

Source

South America 2006, Brazil Subregion

很简单的题,只要先进行一次tarjan,然后缩点,如果两个点在1个强连通分量里的话,就输出0,否则就求最短路,悲催啊,spfa写搓了,WA了2次还RE了2次,还有就是结束条件很坑,是n == 0而不是n 和m同时为0

#include<map>
#include<set>
#include<list>
#include<stack>
#include<queue>
#include<vector>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

const int N  = 510;
const int inf = 0x3f3f3f3f;
int DFN[N];
int low[N];
int block[N];
int Stack[N];
int in[N];
int out[N];
int dist[N];
bool vis[N];
bool instack[N];
int head[N];
int tot, sccnum, index, top, n, m, u, v, w;;
vector<pair<int, int> >edge2[N];
queue<int> qu;

struct node
{
    int weight;
    int next;
    int to;
}edge[N * N];

void addedge(int from, int to, int weight)
{
    edge[tot].weight = weight;
    edge[tot].to = to;
    edge[tot].next = head[from];
    head[from] = tot++;
}

void tarjan(int u)
{
    DFN[u] = low[u] = ++index;
    Stack[top++] = u;
    instack[u] = 1;
    for (int i = head[u]; i != -1; i = edge[i].next)
    {
        int v = edge[i].to;
        if (DFN[v] == 0)
        {
            tarjan(v);
            if (low[u] > low[v])
            {
                low[u] = low[v];
            }
        }
        else if (instack[v])
        {
            if (low[u] > DFN[v])
            {
                low[u] = DFN[v];
            }
        }
    }
    if (DFN[u] == low[u])
    {
        sccnum++;
        do
        {
            top--;
            block[Stack[top]] = sccnum;
            instack[Stack[top]] = 0;
        }while ( top >=0 && Stack[top] != u);
    }
}


void solve()
{
    memset( instack, 0, sizeof(instack) );
    memset( DFN, 0, sizeof(DFN) );
    memset( low, 0, sizeof(low) );
    memset( in, 0, sizeof(in) );
    memset( out, 0, sizeof(out) );
    sccnum = index = top = 0;
    for (int i = 1; i <= n; i++)
    {
        if (DFN[i] == 0)
        {
            tarjan(i);
        }
    }
    for (int i = 1; i <= sccnum; i++)
    {
        edge2[i].clear();
    }
    for (int i = 1; i <= n; i++)
    {
        for (int j = head[i]; j != -1; j = edge[j].next)
        {
            if (block[i] != block[edge[j].to])
            {
                u = block[i];
                v = block[edge[j].to];
                w = edge[j].weight;
                edge2[u].push_back(make_pair(v, w));
            }
        }
    }
}

void spfa(int u)
{
    memset( dist, inf, sizeof(dist) );
    dist[u] = 0;
    while ( !qu.empty() )
    {
        qu.pop();
    }
    qu.push(u);
    while ( !qu.empty() )
    {
        int x = qu.front();
        qu.pop();
        for (int i = 0; i < edge2[x].size(); i++)
        {
            if (dist[edge2[x][i].first] > dist[x] + edge2[x][i].second)
            {
                dist[edge2[x][i].first] = dist[x] + edge2[x][i].second;
                qu.push(edge2[x][i].first);
            }
        }
    }
}
int main()
{
    int q;
    while (~scanf("%d", &n))
    {
        scanf("%d", &m);
        if (!n)
            break;
        memset( head, -1, sizeof(head) );
        tot = 0;
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d%d", &u, &v, &w);
            addedge(u, v, w);
        }
        solve();
        scanf("%d", &q);
        while (q--)
        {
            scanf("%d%d", &u, &v);
            if(block[u] == block[v])
            {
                printf("0\n");
                continue;
            }
            spfa(block[u]);
            if(dist[block[v]] != inf)
            {
                printf("%d\n", dist[block[v]]);
                continue;
            }
            printf("Nao e possivel entregar a carta\n");
        }
        printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.