现在的位置: 首页 > 综合 > 正文

hdu5055——Bob and math problem

2019年02月16日 ⁄ 综合 ⁄ 共 1914字 ⁄ 字号 评论关闭

Bob and math problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 590    Accepted Submission(s): 225

Problem Description
Recently, Bob has been thinking about a math problem.
There are N Digits, each digit is between 0 and 9. You need to use this N Digits to constitute an Integer.
This Integer needs to satisfy the following conditions:
  • 1. must be an odd Integer.
  • 2. there is no leading zero.
  • 3. find the biggest one which is satisfied 1, 2.

Example:
There are three Digits: 0, 1, 3. It can constitute six number of Integers. Only "301", "103" is legal, while "130", "310", "013", "031" is illegal. The biggest one of odd Integer is "301".

 

Input
There are multiple test cases. Please process till EOF.
Each case starts with a line containing an integer N ( 1 <= N <= 100 ).
The second line contains N Digits which indicate the digit $a_1, a_2, a_3, \cdots, a_n. ( 0 \leq a_i \leq 9)$.
 

Output
The output of each test case of a line. If you can constitute an Integer which is satisfied above conditions, please output the biggest one. Otherwise, output "-1" instead.
 

Sample Input
3 0 1 3 3 5 4 2 3 2 4 6
 

Sample Output
301 425 -1
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:  5057 5056 5053 5052 5051 
 

贪心,然后就是注意前导零的情况

#include<map>
#include<set>
#include<list>
#include<stack>
#include<queue>
#include<vector>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

const double pi = acos(-1);

struct node
{
    int x;
    bool vis;
    bool flag;
}a[105];

int cmp(node a, node b)
{
    return a.x > b.x;
}

int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        bool flag = false;
        int pos;
        int mins_odd = 15;
        int cnt = 0, ret = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d", &a[i].x);
            a[i].vis = false;
            if(a[i].x & 1)
            {
                if(mins_odd > a[i].x)
                {
                    mins_odd = a[i].x;
                    pos = i;
                }
                cnt++;
                a[i].flag = flag = true;
            }
            else
            {
            	if(a[i].x == 0)
            	{
	            	ret++;
	            }
                a[i].flag = false;
            }

        }
        if(cnt == 1 && ret + cnt == n && n != 1)
        {
        	printf("-1\n");
            continue;
        }
        if(!flag)
        {
            printf("-1\n");
            continue;
        }
        a[pos].vis = true;
        int t;
        sort(a, a + n, cmp);
        for(int i = 0; i < n; i++)
        {
            if(a[i].vis)
            {
                t = a[i].x;
                continue;
            }
            printf("%d", a[i].x);
        }
        printf("%d\n",t);
    }
    return 0;
}


抱歉!评论已关闭.