现在的位置: 首页 > 综合 > 正文

hdu3974—-Assign the task

2019年02月16日 ⁄ 综合 ⁄ 共 3643字 ⁄ 字号 评论关闭

Assign the task

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 780    Accepted Submission(s): 392

Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and
all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever
a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

 

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

 

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

Sample Input
1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

Sample Output
Case #1: -1 1 2
 

Source
 

Recommend

先dfs改时间戳,那么子树区间就连在一起了,然后就是区间更新单点查询

/*************************************************************************
    > File Name: hdu3974.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2015年01月11日 星期日 20时50分13秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 50110;

struct node
{
	int l, r;
	int add;
	int job;
}tree[N << 2];

vector <int> edge[N];

int s[N], e[N], cnt;
int deg[N];

void dfs (int u)
{
	int m = edge[u].size();
	s[u] = ++cnt;
	for (int i = 0; i < m; ++i)
	{
		int v = edge[u][i];
		dfs (v);
	}
	e[u] = cnt;
}

void pushdown (int p)
{
	if (tree[p].add != -1)
	{
		tree[p << 1].add = tree[p << 1 | 1].add = tree[p].add;
		tree[p << 1].job = tree[p << 1 | 1].job = tree[p].add;
		tree[p].add = -1;
	}
}

void build (int p, int l, int r)
{
	tree[p].l = l;
	tree[p].r = r;
	tree[p].add = -1;
	tree[p].job = -1;
	if (l == r)
	{
		return;
	}
	int mid = (l + r) >> 1;
	build (p << 1, l, mid);
	build (p << 1 | 1, mid + 1, r);
}

void update (int p, int l, int r, int val)
{
	if (l == tree[p].l && r == tree[p].r)
	{
		tree[p].job = val;
		tree[p].add = val;
		return;
	}
	pushdown (p);
	int mid = (tree[p].l + tree[p].r) >> 1;
	if (r <= mid)
	{
		update (p << 1, l, r, val);
	}
	else if (l > mid)
	{
		update (p << 1 | 1, l, r, val);
	}
	else
	{
		update (p << 1, l, mid, val);
		update (p << 1 | 1, mid + 1, r, val);
	}
}

int query (int p, int pos)
{
	if (tree[p].l == tree[p].r)
	{
		return tree[p].job;
	}
	pushdown (p);
	int mid = (tree[p].l + tree[p].r) >> 1;
	if (pos <= mid)
	{
		return query (p << 1, pos);
	}
	else
	{
		return query (p << 1 | 1, pos);
	}
}

int main()
{
	int t, n, m;
	int icase = 1;
	char op[10];
	int x, y;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &n);
		memset (deg, 0, sizeof(deg));
		for (int i = 0; i <= n; ++i)
		{
			edge[i].clear();
		}
		int u, v;
		for (int i = 1; i <= n - 1; ++i)
		{
			scanf("%d%d", &u, &v);
			edge[v].push_back(u);
			deg[u]++;
		}
		int root;
		for (int i = 1; i <= n; ++i)
		{
			if (!deg[i])
			{
				root = i;
				break;
			}
		}
		cnt = 0;
		dfs (root);
		build (1, 1, cnt);
		scanf("%d", &m);
		printf("Case #%d:\n", icase++);
		while (m--)
		{
			scanf("%s", op);
			if (op[0] == 'C')
			{
				scanf("%d", &x);
				printf("%d\n", query(1, s[x]));
			}
			else
			{
				scanf("%d%d", &x, &y);
				int l = s[x];
				int r = e[x];
				update (1, l, r, y);
			}
		}
	}
	return 0;
}

抱歉!评论已关闭.