现在的位置: 首页 > 综合 > 正文

ZOJ3261——Connections in Galaxy War

2019年02月17日 ⁄ 综合 ⁄ 共 3622字 ⁄ 字号 评论关闭
ZOJ Problem Set - 3261

Connections in Galaxy War


Time Limit: 3 Seconds     
Memory Limit:
32768 KB


In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many
problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer
pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star
A directly or indirectly. In addition, this star should be more powerful than the star
A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star
A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains
N integers p0, p1, ... , pn-1 (0 <=
pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer
M (0 <= M <= 20000), that is the number of tunnels built before the war. Then
M lines follows. Each line has two integers a, b (0 <=
a, b <= N - 1, a != b), which means star
a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following
Q lines, each line will be written in one of next two formats.

    "destroy a b" - the connection between star a and star
    b was destroyed by the monsters. It's guaranteed that the connection between star
    a and star b was available before the monsters' attack.

    "query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output
"-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1

Author: MO, Luyi

Source: ZOJ Monthly, November 2009

啊哈,逆序并查集,我们把每一个块的根上的信息更新为这个块里所有点能查到的符合条件的star,然后离线处理下就OK了

#include<map>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

const int N=10010;
int father[N];
int ps[N];
bool vis[N<<1];
struct line
{
	int u,v;
}edge[N<<1];

struct node
{
	bool op;
	int u,v;
}query[5*N];

int ans[5*N];

int max_pow[N];
int max_pos[N];

int find(int x)
{
	if(father[x]==-1)
		return x;
	return father[x]=find(father[x]);
}

void merge(int x,int y)
{
	int a=find(x);
	int b=find(y);
	if(a!=b)
	{
		father[a]=b;
		if(max_pow[a]>max_pow[b])//合成一个集合,如果a访问到的比b大,更新
		{
			max_pos[b]=max_pos[a];
			max_pow[b]=max_pow[a];
		}
		else if(max_pow[a]==max_pow[b] && max_pos[a] < max_pos[b])
			max_pos[b]=max_pos[a];
	}
}

int main()
{
	int n,m,k;
	bool flag=false;
	while(~scanf("%d",&n))
	{
		map<int,int>mat[N];
		if(flag)
			printf("\n");
		else
			flag=true;
		memset(father,-1,sizeof(father));
		memset(vis,false,sizeof(vis));
		for(int i=0;i<n;i++)
		{
			scanf("%d",&ps[i]);
			max_pos[i]=i;
			max_pow[i]=ps[i];
			mat[i].clear();
		}
		scanf("%d",&m);
		char str[11];
		int u,v;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&u,&v);
			edge[i].u=u;
			edge[i].v=v;
			mat[u][v]=i;
			mat[v][u]=i;
		}		
		scanf("%d",&k);
		for(int i=0;i<k;i++)
		{
			scanf("%s",str);
			if(str[0]=='q')
			{
				query[i].op=0;
				scanf("%d",&query[i].u);
			}
			else
			{
				query[i].op=1;
				scanf("%d%d",&u,&v);
				query[i].u=u;
				query[i].v=v;
				int cur=mat[u][v];
				vis[cur]=true;
			}	
		}
		int cnt=0;
		for(int i=0;i<m;i++)
			if(!vis[i])
				merge(edge[i].u,edge[i].v);
		for(int i=k-1;i>=0;i--)
		{
			if(query[i].op==0)
			{
				u=query[i].u;
				int fu=find(u);
				if(max_pow[fu]<=ps[u])
					ans[cnt++]=-1;
				else
					ans[cnt++]=max_pos[fu];
			}
			else
			{
				merge(query[i].u,query[i].v);
			}
		}
		for(int i=cnt-1;i>=0;i--)
			printf("%d\n",ans[i]);
	}
	return 0;
}


抱歉!评论已关闭.