现在的位置: 首页 > 综合 > 正文

POJ3616——Milking Time

2019年02月17日 ⁄ 综合 ⁄ 共 2338字 ⁄ 字号 评论关闭
Milking Time
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4964   Accepted: 2076

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next
N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval
i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri <
ending_houriN), and a corresponding efficiency (1 ≤
efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked,
Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest
R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the
N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers:
starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the
N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

USACO 2007 November Silver

dp,采用记忆化搜索,按题目意思建边就行

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 1000010;
int dp[1010];
int head[1010];
int w[1010];
int tot;

struct kode
{
	int next;
	int to;
}edge[1010 * 1010];

struct node
{
	int l, r, eff;
}hour[1010];

void addedge(int from, int to)
{
	edge[tot].to = to;
	edge[tot].next = head[from];
	head[from] = tot++;
}

int dfs(int u)
{
	if (dp[u])
	{
		return dp[u];
	}
	for (int i = head[u]; ~i; i = edge[i].next)
	{
		int v = edge[i].to;
		dp[u] = max(dp[u], dfs(v));
	}
	dp[u] += w[u];
	return dp[u];
}

int main()
{
	int n, m, r;
	while (~scanf("%d%d%d", &n, &m, &r))
	{
		memset (head, -1, sizeof(head));
		memset (dp, 0, sizeof(dp));
		tot = 0;
		for (int i = 1; i <= m; ++i)
		{
			scanf("%d%d%d", &hour[i].l, &hour[i].r, &hour[i].eff);
			w[i] = hour[i].eff;
		}
		for (int i = 1; i <= m; ++i)
		{
			for (int j = i + 1; j <= m; ++j)
			{
				if (hour[i].r + r <= hour[j].l)
				{
					addedge(i, j);
					// printf("%d -- %d\n", i, j);
				}
				else if (hour[j].r + r <= hour[i].l)
				{
					addedge(j, i);
					// printf("%d -- %d\n", j, i);
				}
			}
		}
		int ans = 0;
		for (int i = 1; i <= m; ++i)
		{
			ans = max(ans, dfs(i));
		}
		printf("%d\n", ans);
	}
	return 0;
}

抱歉!评论已关闭.