现在的位置: 首页 > 综合 > 正文

POJ1179——Polygon

2019年02月17日 ⁄ 综合 ⁄ 共 3322字 ⁄ 字号 评论关闭
Polygon
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 4975   Accepted: 2090

Description

Polygon is a game for one player that starts on a polygon with N vertices, like the one in Figure 1, where N=4. Each vertex is labelled with an integer and each edge is labelled with either the symbol + (addition) or the symbol
* (product). The edges are numbered from 1 to N.


On the first move, one of the edges is removed. Subsequent moves involve the following steps:
�pick an edge E and the two vertices V1 and V2 that are linked by E; and
�replace them by a new vertex, labelled with the result of performing the operation indicated in E on the labels of V1 and V2.
The game ends when there are no more edges, and its score is the label of the single vertex remaining.

Consider the polygon of Figure 1. The player started by removing edge 3. After that, the player picked edge 1, then edge 4, and, finally, edge 2. The score is 0.



Write a program that, given a polygon, computes the highest possible score and lists all the edges that, if removed on the first move, can lead to a game with that score.

Input

Your program is to read from standard input. The input describes a polygon with N vertices. It contains two lines. On the first line is the number N. The second line contains the labels of edges 1, ..., N, interleaved with the
vertices' labels (first that of the vertex between edges 1 and 2, then that of the vertex between edges 2 and 3, and so on, until that of the vertex between edges N and 1), all separated by one space. An edge label is either the letter t (representing +) or
the letter x (representing *).

3 <= N <= 50
For any sequence of moves, vertex labels are in the range [-32768,32767].

Output

Your program is to write to standard output. On the first line your program must write the highest score one can get for the input polygon. On the second line it must write the list of all edges that, if removed on the first move,
can lead to a game with that score. Edges must be written in increasing order, separated by one space.

Sample Input

4
t -7 t 4 x 2 x 5

Sample Output

33
1 2

Source

IOI 1998

好题!!
区间dp,枚举删除的边, 然后一开始无脑想到了这个方程 dp[i][j] = max(dp[i][k] + or * dp[k + 1]j]);
但是,存在一些情况是由左右两边负负得正得到的最大值,那么此时所需要的值并没有在之前保存下来,所以无法得到正确值

我们设f1[i][j], f2[i][j]表示从i处理到j所能得到的最大值以及最小值

对于f1
如果是‘+’,那么肯定是最大的+最大的得到最大的
如果是‘*‘,那么可能是大*大,大*小,小*大,小*小

对于f2
如果是’+‘,那么肯定是最小的+最小的得到最小的
如果是’*‘,那么可能是 大*大, 小*小, 大*小,小*大

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 55;
const int inf = 0x3f3f3f3f;

int num[N];
int edge[N];
char op[N];
int f1[N * 2][N * 2], f2[N * 2][N * 2];

int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		memset (f1, -inf, sizeof(f1));
		memset (f2, inf, sizeof(f2));
		for (int i = 1; i <= n; ++i)
		{
			getchar();
			scanf("%c%*c%d", &op[i], &num[i]);
		}
		for (int i = 1; i < n; ++i)
		{
			op[i + n] = op[i];
			num[i + n] = num[i];
		}
		for (int i = 1; i <= 2 * n - 1; ++i)
		{
			f1[i][i] = f2[i][i] = num[i];
		}
		for (int i = 2 * n - 1; i >= 1; --i)
		{
			for (int j = i + 1; j <= 2 * n - 1; ++j)
			{
				for (int k = i; k < j; ++k)
				{
					if (op[k + 1] == 't')// +
					{
						f1[i][j] = max(f1[i][j], f1[i][k] + f1[k + 1][j]);
						f2[i][j] = min(f2[i][j], f2[i][k] + f2[k + 1][j]);
					}
					else// * 
					{
						f1[i][j] = max(f1[i][j], f1[i][k] * f1[k + 1][j]);
						f1[i][j] = max(f1[i][j], f1[i][k] * f2[k + 1][j]);
						f1[i][j] = max(f1[i][j], f2[i][k] * f1[k + 1][j]);
						f1[i][j] = max(f1[i][j], f2[i][k] * f2[k + 1][j]);
						f2[i][j] = min(f2[i][j], f1[i][k] * f2[k + 1][j]);
						f2[i][j] = min(f2[i][j], f2[i][k] * f1[k + 1][j]);
						f2[i][j] = min(f2[i][j], f2[i][k] * f2[k + 1][j]);
						f2[i][j] = min(f2[i][j], f1[i][k] * f1[k + 1][j]);
					}
				}
			}
		}
		int ans = -inf, cnt = 0;
		for (int i = 1; i <= n; ++i)
		{
			ans = max(ans, f1[i][i + n - 1]);
		}
		for (int i = 1; i <= n; ++i)
		{
			if (ans == f1[i][i + n - 1])
			{
				edge[cnt++] = i;
			}
		}
		printf("%d\n", ans);
		printf("%d", edge[0]);
		for (int i = 1; i < cnt; ++i)
		{
			printf(" %d", edge[i]);
		}
		printf("\n");
	}
	return 0;
}

抱歉!评论已关闭.