现在的位置: 首页 > 综合 > 正文

POJ3356——AGTC

2019年02月17日 ⁄ 综合 ⁄ 共 2322字 ⁄ 字号 评论关闭
AGTC
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10218   Accepted: 3946

Description

Let x and y be two strings over some finite alphabet A. We would like to transform
x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in
x is m and the number of letters in y is n where
nm.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string
x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string
x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

Source

Manila 2006

类似LCS的题
DP果然是硬伤啊,这么简单的题,居然忘记初始化-.-
设dp[i][j]表示x字符串匹配到i,y字符串匹配到j时的最小操作数目
如果当前字符相同,那么方案是

dp[i][j] = min(dp[i - 1][j - 1], min(dp[i][j - 1] + 1, dp[i - 1][j] + 1));

dp[i][j-1]相当于在y中删除一个字符,和在x中插入一个字符等价,dp[i-1][j]相当于在x中删除一个字符
如果当前字符不同,那么方案就是

dp[i][j] = min(dp[i - 1][j - 1] + 1, min(dp[i][j - 1] + 1, dp[i - 1][j] + 1));

#include <map>
#include <set>
#include <list>
#include <stack>
#include <vector>
#include <bitset>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <iterator>

using namespace std;

int dp[1010][1010];

char str1[1010];
char str2[1010];

int main()
{
	int m, n;
	while (~scanf("%d%s%d%s", &m, str1, &n, str2))
	{
		memset ( dp, 0, sizeof(dp) );
		for (int i = 0; i <= m; i++)
		{
			dp[i][0] = i;
		}
		for (int i = 0; i <= n; i++)
		{
			dp[0][i] = i;
		}
		if (str1[0] != str2[0])
		{
			dp[0][0] = 1;
		}
		for (int i = 1; i < m; i++)
		{
			for (int j = 1; j < n; j++)
			{
				if (str1[i] == str2[j])
				{
					dp[i][j] = min(dp[i - 1][j - 1], min(dp[i][j - 1] + 1, dp[i - 1][j] + 1));
				}
				else
				{
					dp[i][j] = min(dp[i - 1][j - 1] + 1, min(dp[i][j - 1] + 1, dp[i - 1][j] + 1));
				}
			}
		}
		printf("%d\n", dp[m - 1][n - 1]);
	}
	return 0;
}

抱歉!评论已关闭.