现在的位置: 首页 > 综合 > 正文

hdu1754——I Hate It

2019年02月18日 ⁄ 综合 ⁄ 共 1630字 ⁄ 字号 评论关闭

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 39849    Accepted Submission(s): 15806

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin
 

Author
linle
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1698 1542 2795 1540 1255

复习了下zkw树

#include<map>  
#include<set>  
#include<list>  
#include<stack>  
#include<queue>  
#include<vector>  
#include<cmath>  
#include<cstdio>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
  
using namespace std; 

const int N = 200010;
int tree[N << 2];
int M;

void build(int n)
{
	for(M = 1; M <= n + 1; M <<= 1);
	for(int i = M + 1; i <= M + n; i++)
		scanf("%d", &tree[i]);
	for(int i = M - 1; i; i--)
		tree[i] = max(tree[i << 1], tree[i << 1 | 1]);
}

void update(int p, int val)
{
	for(tree[p += M] = val, p >>= 1; p; p >>= 1)
		tree[p] = max(tree[p << 1], tree[p << 1 | 1]);
}

void query(int s, int t)
{
	int maxs = -1;
	for(s += M - 1, t += M + 1; s ^ t ^ 1; s >>= 1, t >>= 1)
	{
		if(~s & 1)
			maxs = max(maxs, tree[s ^ 1]);
		if(t & 1)
			maxs = max(maxs, tree[t ^ 1]);
	}
	printf("%d\n", maxs);
}
int main()
{
	int n, m;
	while(~scanf("%d%d", &n, &m))
	{
		build(n);
		char op[10];
		int x, y;
		while(m--)
		{
			scanf("%s", op);
			if(op[0] == 'Q')
			{
				scanf("%d%d", &x, &y);
				query(x, y);
			}
			else
			{
				scanf("%d%d", &x, &y);
				update(x, y);
			}
		}
	}
	return 0;
}

抱歉!评论已关闭.