现在的位置: 首页 > 综合 > 正文

POJ2155——Matrix

2019年02月18日 ⁄ 综合 ⁄ 共 2076字 ⁄ 字号 评论关闭

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

很好的题啊,一开始想错更新方向了,怎么都想不通.....
求某个点的值就是求这个点的更新次数,因为这个矩阵是01矩阵

而求这个点的更新次数又可以转化为求树状数组子矩阵 (1,1)---(x,y)的和,可以这么想,所有会让点(x,y)修改的点都在他左上方的矩阵上,那么那些点每更新一次,点(x,y)也要更新一次

#include<stack>
#include<queue>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

const int N=1010;
int tree[N][N];

int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int y)
{
    for (int i=x;i<=N;i+=lowbit(i))
        for (int j=y;j<=N;j+=lowbit(j))
            tree[i][j]++;
}

int sum(int x,int y)
{
    int ans=0;
    for (int i=x;i;i-=lowbit(i))
        for (int j=y;j;j-=lowbit(j))
            ans+=tree[i][j];
    return ans;
}

int main()
{
    int x,n,T,x1,y1,x2,y2;
    char op[3];
    scanf("%d",&x);
    while (x--)
    {
        scanf("%d%d",&n,&T);
        memset(tree,0,sizeof(tree));
        while (T--)
        {
            scanf("%s",op);
            if (op[0]=='C')
            {
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                add(x1,y1);
                add(x1,y2+1);
                add(x2+1,y1);
                add(x2+1,y2+1);
            }
            else
            {
                scanf("%d%d",&x1,&y1);
                printf("%d\n",sum(x1,y1)%2);
            }
        }
       	printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.