现在的位置: 首页 > 综合 > 正文

POJ2481——Cows

2019年02月18日 ⁄ 综合 ⁄ 共 2152字 ⁄ 字号 评论关闭

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a
range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU

树状数组解决,首先对区间排序,先按右边从大到小,再按左边从小到大,这样保证第i个区间的右边一定是在第i-1个的之前,也就是能覆盖它的区间一定在他左边
然后每次更新这个区间在树状数组里的值,但是对于区间相同的情况要特判,否则就直接用树状数组求和的函数求出能覆盖它的区间的个数就好了

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int ans[100005];
int tree[100010];
struct node
{
    int s,e;
    int num;
}cows[100005];
int n;
int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int val)
{
    for (int i=x;i<=n;i+=lowbit(i))
        tree[i]+=val;
}

int sum(int x)
{
    int ans=0;
    for (int i=x;i;i-=lowbit(i))
        ans+=tree[i];
    return ans;
}

int cmp(node a,node b)
{
    if (a.e!=b.e)
        return a.e>b.e;
    return a.s<b.s;
}

int main()
{
    while (~scanf("%d",&n) && n)
    {
        memset(tree,0,sizeof(tree));
        for (int i=1;i<=n;i++)
        {
            scanf("%d%d",&cows[i].s,&cows[i].e);
            cows[i].s++;
            cows[i].e++;
            cows[i].num=i;
        }
        sort(cows+1,cows+n+1,cmp);
        ans[cows[1].num]=0;
        add(cows[1].s,1);
        for (int i=2;i<=n;i++)
        {
            if (cows[i-1].s==cows[i].s && cows[i-1].e==cows[i].e)
                ans[cows[i].num]=ans[cows[i-1].num];
            else
                ans[cows[i].num]=sum(cows[i].s);
            add(cows[i].s,1);
        }
        printf("%d",ans[1]);
        for (int i=2;i<=n;i++)
            printf(" %d",ans[i]);
        printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.