现在的位置: 首页 > 综合 > 正文

hdu3415——Max Sum of Max-K-sub-sequence

2019年02月18日 ⁄ 综合 ⁄ 共 2594字 ⁄ 字号 评论关闭

Max Sum of Max-K-sub-sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6130    Accepted Submission(s): 2234

Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.

Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum
start position, if still more than one , output the minimum length of them.
 

Sample Input
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 

Sample Output
7 1 3 7 1 3 7 6 2 -1 1 1
 

Author
shǎ崽@HDU
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  3423 3417 3418 3419 3421

先把环变成链,然后就是在1 - 2 * n - 1之间求
求出前缀和,那么ans = max(sum[i] - sum[j - 1])而且 i - j + 1 <=k

用一个单调队列来维护sum[j - 1],边维护边记录答案

PS:这题应该还能用线段树,RMQ等方法解决

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 200010;

int dp[N], arr[N];
int in_que[N], sum[N];

int main()
{
	int n, t, k;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d", &n, &k);
		sum[0] = 0;
		for (int i = 1; i <= n; ++i)
		{
			scanf("%d", &arr[i]);
			sum[i] = sum[i - 1] + arr[i];
		}
		for (int i = n + 1; i < 2 * n; ++i)
		{
			sum[i] = sum[i - 1] + arr[i - n];
		}
		int front = 0, rear = 0;
		int s, e, maxs = -0x3f3f3f3f;
		for (int i = 1; i <= k; ++i)
		{

			while (front < rear && sum[in_que[rear - 1]] >= sum[i - 1])
			{
				rear--;
			}
			in_que[rear++] = i - 1;
			// printf("%d %d\n", sum[in_que[front]], sum[i]);
			if (maxs < sum[i] - sum[in_que[front]])
			{
				maxs = sum[i] - sum[in_que[front]];
				s = in_que[front] + 1;
				e = i;
			}
			else if (maxs == sum[i] - sum[in_que[front]] && in_que[front] + 1 < s)
			{
				s = in_que[front] + 1;
			}
			else if (maxs == sum[i] - sum[in_que[front]] && in_que[front] + 1 == s && e > i)
			{
				e = i;
			}
			// printf("%d\n", in_que[front]);
		}
		for (int i = k + 1; i < 2 * n; ++i)
		{
			while (front < rear && sum[in_que[rear - 1]] >= sum[i - 1])
			{
				rear--;
			}
			in_que[rear++] = i - 1;
			if (in_que[front] < i - k)
			{
				front++;
			}
			if (maxs < sum[i] - sum[in_que[front]])
			{
				maxs = sum[i] - sum[in_que[front]];
				s = in_que[front] + 1;
				e = i;
			}
			else if (maxs == sum[i] - sum[in_que[front]] && in_que[front] + 1 < s)
			{
				s = in_que[front] + 1;
			}
			else if (maxs == sum[i] - sum[in_que[front]] && in_que[front] + 1 == s && e > i)
			{
				e = i;
			}
		}
		if (s > n)
		{
			s -= n;
		}
		if (e > n)
		{
			e -= n;
		}
		printf("%d %d %d\n", maxs, s, e);
	}
	return 0;
}
 

抱歉!评论已关闭.