现在的位置: 首页 > 综合 > 正文

SDUTRescue The Princess(数学问题)

2019年02月21日 ⁄ 综合 ⁄ 共 2408字 ⁄ 字号 评论关闭

题目描述

    Several
days ago, a beast caught a beautiful princess and the princess was put in prison. To rescue the princess, a prince who wanted to marry the princess set out immediately. Yet, the beast set a maze. Only if the prince find out the maze’s exit can he save the
princess.

    Now, here
comes the problem. The maze is a dimensional plane. The beast is smart, and he hidden the princess snugly. He marked two coordinates of an equilateral triangle in
the maze. The two marked coordinates are A(x1,y1) and B(x2,y2). The third coordinate
C(x3,y3) is the maze’s exit. If the prince can find out the exit, he can save the princess. After the prince comes into the maze, he finds out the A(x1,y1)
and B(x2,y2), but he doesn’t know where the C(x3,y3) is. The prince need your help.
Can you calculate the C(x3,y3)
and tell him?

输入

    The first
line is an integer T(1 <= T <= 100) which is the number of test cases. T test cases follow. Each test case contains two coordinates A(x1,y1) and B(x2,y2),
described by four floating-point numbers x1, y1, x2, y2 ( |x1|,
|y1|, |x2|, |y2| <= 1000.0).
    Please notice that A(x1,y1)
and B(x2,y2) and C(x3,y3) are in an anticlockwise direction from the equilateral triangle.
And coordinates A(x1,y1) and B(x2,y2) are given by anticlockwise.

输出

    For each test case, you should output the coordinate of C(x3,y3),
the result should be rounded to 2 decimal places in a line.

示例输入

4
-100.00 0.00 0.00 0.00
0.00 0.00 0.00 100.00
0.00 0.00 100.00 100.00
1.00 0.00 1.866 0.50

示例输出

(-50.00,86.60)
(-86.60,50.00)
(-36.60,136.60)
(1.00,1.00)

提示

 

来源

2013年山东省第四届ACM大学生程序设计竞赛
分两种:一种是A点B点的x坐标相同,二种:X坐标不相同。
#include<stdio.h>
#include<math.h>
int main()
{
    double b[2],c[3],a,x[3],y[3],tx[2],ty[2],k,bb,edglen;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf",&x[0],&y[0],&x[1],&y[1]);
        if(x[0]==x[1])
        {
            edglen=sqrt(pow(x[0]-x[1],2.0)+pow(y[0]-y[1],2.0));
            tx[0]=x[0]+sqrt(3.0)/2*edglen;
            tx[1]=x[0]-sqrt(3.0)/2*edglen;
            if(y[1]>y[0])
            {
                ty[0]=y[0]+edglen/2;
                printf("(%.2lf,%.2lf)\n",tx[1],ty[0]);
            }
            else
            {
                ty[0]=y[1]+edglen/2;
                printf("(%.2lf,%.2lf)\n",tx[0],ty[0]);
            }
            continue;
        }
        c[0]=(x[0]*x[0]-x[1]*x[1]+y[0]*y[0]-y[1]*y[1])/(2*x[0]-2*x[1]);
        b[0]=-(y[0]-y[1])/(x[0]-x[1]);
        a=b[0]*b[0]+1;  b[1]=2*(c[0]*b[0]-x[1]*b[0]-y[1]);
        c[1]=x[0]*x[0]-2*x[0]*x[1]+y[0]*y[0]-2*y[0]*y[1];
        c[2]=c[0]*c[0]-2*c[0]*x[1]-c[1];
        k=-b[0]; bb=y[0]-k*x[0];
        ty[0]=(-b[1]+sqrt(b[1]*b[1]-4*a*c[2]))/(2*a);tx[0]=c[0]+b[0]*ty[0];
        ty[1]=(-b[1]-sqrt(b[1]*b[1]-4*a*c[2]))/(2*a);tx[1]=c[0]+b[0]*ty[1];
        if(x[0]<x[1])
        {
            if(ty[0]-k*tx[0]-bb>0)
            {
                x[2]=tx[0];y[2]=ty[0];
            }
            else
            {
                 x[2]=tx[1];y[2]=ty[1];
            }
        }
        else if(x[0]>x[1])
        {
             if(ty[0]-k*tx[0]-bb<0)
            {
                x[2]=tx[0];y[2]=ty[0];
            }
            else
            {
                 x[2]=tx[1];y[2]=ty[1];
            }
        }
        printf("(%.2lf,%.2lf)\n",x[2],y[2]);
    }

}

抱歉!评论已关闭.