现在的位置: 首页 > 综合 > 正文

hdu1391(Number Steps )

2019年02月21日 ⁄ 综合 ⁄ 共 915字 ⁄ 字号 评论关闭
Problem Description
Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

Input
The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

Output
For each point in the input, write the number written at that point or write No Number if there is none.

Sample Input
3 4 2 6 6 3 4

Sample Output
6 12 No Number
#include<stdio.h>
int main()
{
    int x,y,a,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&x,&y);
        if(y==x)//上边那直线
        {
            if(x%2==0)
            a=2*x;
            else
            a=1+4*((x+1)/2-1);
            printf("%d\n",a);
        }
        else if(y==x-2)//下边直线
        {
            if(x%2==0)
            a=2*(x-1);
            else
            a=3+4*((x-1)/2-1);
            printf("%d\n",a);
        }
        else
        printf("No Number\n");
    }
}

抱歉!评论已关闭.