现在的位置: 首页 > 综合 > 正文

hdu1339

2019年02月21日 ⁄ 综合 ⁄ 共 788字 ⁄ 字号 评论关闭
Problem Description
Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

Example

For n = 24, o = 3 and p = 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

Sample Input
1 24

Sample Output
3 3
#include<stdio.h>
int main()
{
    int n,t,o,p;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        p=0;
        while(n%2==0)
        {
            p++;
            n/=2;
        }
        o=n;
        printf("%d %d\n",o,p);
    }
}
【上篇】
【下篇】

抱歉!评论已关闭.