现在的位置: 首页 > 综合 > 正文

hdu 4268 Alice and Bob(multiset|线段树)

2019年04月11日 ⁄ 综合 ⁄ 共 2734字 ⁄ 字号 评论关闭

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2901    Accepted Submission(s): 941

Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height
of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.

For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and
width of Alice's card, then the following N lines means that of Bob's.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4
 

Sample Output
1 2
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  4272 4277 4273 4270 4269 
 题意:
A,B两个人各有n个矩形。(n<=1e5)现在A想用自己的矩形覆盖B的矩形。一个矩形覆盖另一个矩形的条件是宽和高都不另一个矩形对应的宽和高小。现在问A最多能覆盖B的多少个矩形。每个矩形最多覆盖一个另一个矩形。且矩形不能旋转。
思路:
就是贪心的思想。先把两个人的矩形都按w排序。然后对于A的每一个矩形。找一个w<=自己w.h<自己H且尽量接近的B的矩形覆盖就行了。覆盖后删除这两个矩形。对于找上述条件的矩形可以用multiset维护。但是比赛时换了种姿势用线段树写了发。思路都差不多。离散化。维护区间和。找小于等于p且最靠右的位置。
详细见代码:
#include <iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define lson L,mid,ls
#define rson mid+1,R,rs
const int maxn=100010;
int num[maxn<<3];//离散化后有2*n忘了改大空间了。坑
struct node
{
    int w,h;
} ag[maxn],bg[maxn];
int H[maxn<<1];
inline bool cmp(const node &a,const node &b)
{
    if(a.w==b.w)
        return a.h<b.h;
    return a.w<b.w;
}
void build(int L,int R,int rt)
{
    num[rt]=0;
    if(L==R)
        return ;
    int ls=rt<<1,rs=ls|1,mid=(L+R)>>1;
    build(lson);
    build(rson);
}
void update(int L,int R,int rt,int p,int d)
{
    if(L==R)
    {
        num[rt]+=d;
        return;
    }
    int ls=rt<<1,rs=ls|1,mid=(L+R)>>1;
    if(p<=mid)
        update(lson,p,d);
    else
        update(rson,p,d);
    num[rt]=num[ls]+num[rs];
}
int qu(int L,int R,int rt,int p)
{
    if(!num[rt])
        return -1;
    if(L==R)
        return L;
    int ls=rt<<1,rs=ls|1,mid=(L+R)>>1,pos=-1;
    if(p<=mid)
        return qu(lson,p);
    if(num[rs])
         pos=qu(rson,p);
    if(pos!=-1)
        return pos;
    return qu(lson,p);
}
int main()
{
    int t,n,i,m,p,ans;

    scanf("%d",&t);
    while(t--)
    {
        m=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&ag[i].h,&ag[i].w);
            H[m++]=ag[i].h;
        }
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&bg[i].h,&bg[i].w);
            H[m++]=bg[i].h;
        }
        sort(ag,ag+n,cmp);
        sort(bg,bg+n,cmp);
        sort(H,H+m);
        m=unique(H,H+m)-H;
        build(1,m,1);
        ans=p=0;
        for(i=0;i<n;i++)
        {
            while(p<n&&bg[p].w<=ag[i].w)
                update(1,m,1,lower_bound(H,H+m,bg[p].h)-H+1,1),p++;
            int pos=qu(1,m,1,lower_bound(H,H+m,ag[i].h)-H+1);
            if(pos!=-1)
            {
                ans++;
                update(1,m,1,pos,-1);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.