现在的位置: 首页 > 算法 > 正文

hdu 1043 poj 1077 Eight Time (搜索&八数码)

2019年04月12日 算法 ⁄ 共 4450字 ⁄ 字号 评论关闭

Eight

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10351    Accepted Submission(s): 2755
Special Judge

Problem Description
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one
tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:

 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and

frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three

arrangement.

 

Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within
a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

 

Output
You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string
should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
 

Sample Input
2 3 4 1 5 x 7 6 8
 

Sample Output
ullddrurdllurdruldr
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1044 1072 1180 1067 1401 
 

题意:

就是还原八数码。输出操作。

思路:

利用康拓展开判重。通过康拓展开知一共有362879种状态。用逆序数判断可行解见八数码可行解。然后宽搜。

详细见代码:

#include<algorithm>
#include<iostream>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string>
#include<queue>
#include<set>
#include<map>
//#pragma comment(linker,"/STACK:1024000000,1024000000")
using namespace std;
const int INF=0x3f3f3f3f;
const double eps=1e-8;
const double PI=acos(-1.0);
const int maxn=370010;//最大为362879
const int num=9;
const int over=46233;
typedef __int64 ll;
int c[10],head,tail;
int vis[maxn];
int fac[15]={1,1,2,6,24,120,720,5040,40320,362880,3628800,39916800,479001600};//存阶乘
int dx[4]={-1,1,-3,3};//四个方向
map<int,char> mpp;
struct yb
{
    int mp[10];
    int bp,pre,code,dre;//空格位置。上一状态的下标(记录路径),康拓展开,方向。
} q[maxn],tp,tt;
/***********树状数组求逆序数(规模比较小快不了多少)***********/
int lowbit(int x)
{
    return x&-x;
}
void update(int x)
{
    while(x<=num)
    {
        c[x]++;
        x+=lowbit(x);
    }
}
int getsum(int x)
{
    int sum=0;
    while(x>0)
    {
        sum+=c[x];
        x-=lowbit(x);
    }
    return sum;
}
/***************康拓展开***************/
ll contor(int arr[])
{
    int i,j,ct;
    ll sum=0;

    for(i=0;i<num;i++)
    {
        ct=0;
        for(j=i+1;j<num;j++)
            if(arr[j]<arr[i])
                ct++;
        sum+=ct*fac[num-i-1];
    }
    return sum;
}
bool ok(int px,int x,int dre)//判断是否越界
{
    int lim=((px+3)/3)*3-1;
    if(x<0||x>=num)
        return false;
    if(dre>1)
        return true;
    if(x>lim||x<lim-2)
        return false;
    return true;
}

void bfs()
{
    int i,x;
    memset(vis,0,sizeof vis);
    vis[tp.code=contor(tp.mp)]=1;
    tp.pre=-1;
    head=tail=0;
    q[tail++]=tp;
    while(head<tail)
    {
        tp=q[head];
        if(tp.code==over)
            return;
        for(i=0;i<4;i++)
        {
            x=tp.bp+dx[i];
            if(ok(tp.bp,x,i))
            {
                tt=tp;
                tt.mp[tt.bp]=tt.mp[x];
                tt.mp[x]=0;
                tt.code=contor(tt.mp);
                if(!vis[tt.code])
                {
                    vis[tt.code]=1;
                    tt.bp=x;
                    tt.pre=head;
                    tt.dre=i;
                    q[tail++]=tt;
                }
            }
        }
        head++;
    }
}
void print(int x)//输出路径
{
    if(q[x].pre==-1)
    {
        //show(q[x].mp);
        return;
    }
    print(q[x].pre);
    printf("%c",mpp[q[x].dre]);
    //show(q[x].mp);
}
int main()
{
    int i,ni,ct;
    char com[10];
    mpp.clear();
    mpp[0]='l';//建立方向和下标的映射
    mpp[1]='r';
    mpp[2]='u';
    mpp[3]='d';
    while(~scanf("%s",com))
    {
        ct=0;
        if(com[0]!='x')
            tp.mp[0]=com[0]-'0';
        else
            tp.mp[0]=0,tp.bp=0;
        for(i=1;i<9;i++)
        {
            scanf("%s",com);
            if(com[0]!='x')
                tp.mp[i]=com[0]-'0';
            else
                tp.mp[i]=0,tp.bp=i;
        }
        for(i=0;i<9;i++)
            if(tp.mp[i])
                tt.mp[ct++]=tp.mp[i];
        ni=0;
        memset(c,0,sizeof c);
        for(i=0;i<8;i++)//求逆序数
        {
            update(tt.mp[i]);
            ni+=i+1-getsum(tt.mp[i]);
        }
        if(ni&1)
        {
            printf("unsolvable\n");
            continue;
        }
        bfs();
        print(head);
        printf("\n");
    }
    return 0;
}
/******************debug********************/
void show(int arr[])
{
    int i,j;
    for(i=0;i<3;i++)
    {
        for(j=0;j<3;j++)
        {
            printf("%d ",arr[i*3+j]);
        }
        printf("\n");
    }
    printf("--------------------\n");
    getchar();
}

抱歉!评论已关闭.