现在的位置: 首页 > 算法 > 正文

poj 2046 Gap(dfs&hash&壮压)

2019年04月12日 算法 ⁄ 共 3826字 ⁄ 字号 评论关闭
Gap
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 1595   Accepted: 724

Description

Let's play a card game called Gap. 
You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card. 

First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout. 



Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: "11" to the top row, "21" to the next, and so on. 

Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout. 



At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of "42" is "43", and "27" has no successor. 

In the above layout, you can move "43" to the gap at the right of "42", or "36" to the gap at the right of "35". If you move "43", a new gap is generated to the right of "16". You cannot move any card to the right of a card of value 7, nor to the right of a
gap. 

The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows. 



Your task is to find the minimum number of moves to reach the goal layout.

Input

The input starts with a line containing the number of initial layouts that follow. 

Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards. 

Output

For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout,
produce "-1".

Sample Input

4

12 13 14 15 16 17 21
22 23 24 25 26 27 31
32 33 34 35 36 37 41
42 43 44 45 46 47 11

26 31 13 44 21 24 42
17 45 23 25 41 36 11
46 34 14 12 37 32 47
16 43 27 35 22 33 15

17 12 16 13 15 14 11
27 22 26 23 25 24 21
37 32 36 33 35 34 31
47 42 46 43 45 44 41

27 14 22 35 32 46 33
13 17 36 24 44 21 15
43 16 45 47 23 11 26
25 37 41 34 42 12 31

Sample Output

0
33
60
-1

Source

题意:

如图分部这的卡片,每次移动一个空格,让比空格左边的数大一的数移动到空格。最后达到目标状态。问最少的步数。

思路:

关键在于hash。然后就是简单的bfs和判重了。。。

#include<algorithm>
#include<iostream>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string>
#include<queue>
#include<set>
#include<map>
//#pragma comment(linker,"/STACK:1024000000,1024000000")
using namespace std;
const int INF=0x3f3f3f3f;
const double eps=1e-8;
const double PI=acos(-1.0);
const int maxn=100010;
const int mod=1000007;
typedef __int64 ll;
/*
int aim[4][8]=
{
    {11,12,13,14,15,16,17,0},
    {21,22,23,24,25,26,27,0},
    {31,32,33,34,35,36,37,0},
    {41,42,43,44,45,46,47,0}
};
*/
ll over=98430874871LL;//最终状态值
ll base[33];
struct yb
{
    int bx[4],by[4],maze[4][8];//四个空格的位置和整个图
    ll step;
    ll cod;//状态值
} tmp;
struct HASHMAP//hash结构体
{
    int head[mod],next[mod],sz;
    ll st[mod];
    void init()
    {
        sz=0;
        memset(head,-1,sizeof head);
    }
    bool Insert(ll code)
    {
        int i,h=code%mod;
        for(i=head[h];i!=-1;i=next[i])
            {
                if(st[i]==code)
                return true;
            }
        st[sz]=code;
        next[sz]=head[h];
        head[h]=sz++;
        return false;
    }
} hm;
queue<yb> q;
ll getcode(int st[][8])//壮压
{
    int i,j;
    ll tp=0;
    for(i=0;i<4;i++)
        for(j=0;j<8;j++)
            tp+=st[i][j]*base[i*8+j];//都这么压。表示怀疑。
    return tp;
}
ll bfs()
{
    int x,y,i,j,k;
    yb tt;
    while(!q.empty())
        q.pop();
    q.push(tmp);
    while(!q.empty())
    {
        tt=q.front();
        if(tt.cod==over)
            return tt.step;
        for(k=0;k<4;k++)
        {
            tmp=tt;
            x=tmp.bx[k];
            y=tmp.by[k];
            if(tmp.maze[x][y-1]==0)
                continue;
            for(i=0;i<4;i++)
            {
                for(j=0;j<8;j++)
                {
                    if(tmp.maze[i][j]!=tmp.maze[x][y-1]+1)//连续空格
                        continue;
                    tmp.maze[x][y]=tmp.maze[i][j];
                    tmp.maze[i][j]=0;
                    tmp.bx[k]=i;
                    tmp.by[k]=j;
                    if(!hm.Insert(tmp.cod=getcode(tmp.maze)))
                    {
                        tmp.step++;
                        q.push(tmp);
                    }
                }
            }
        }
        q.pop();
    }
    return -1;
}
int main()
{
    int i,j,k,n,tt,cnt;

    base[0]=1;
    for(i=1;i<=33;i++)
        base[i]=base[i-1]<<1;
    while(~scanf("%d",&n))
    {
        for(k=0;k<n;k++)
        {
            hm.init();
            cnt=0;
            for(i=0;i<4;i++)
            {
                tmp.maze[i][0]=(i+1)*10+1;
                for(j=1;j<8;j++)
                {
                    scanf("%d",&tt);
                    if(tt%10==1)
                    {
                        tmp.maze[i][j]=0;
                        tmp.bx[cnt]=i;
                        tmp.by[cnt++]=j;
                    }
                    else
                        tmp.maze[i][j]=tt;
                }
            }
            tmp.step=0;
            tmp.cod=getcode(tmp.maze);
            printf("%I64d\n",bfs());
        }
    }
    return 0;
}

抱歉!评论已关闭.