现在的位置: 首页 > 综合 > 正文

hdu 4122 Alice’s mooncake shop(单调队列)

2019年04月13日 ⁄ 综合 ⁄ 共 4320字 ⁄ 字号 评论关闭

Alice's mooncake shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2559    Accepted Submission(s): 609

Problem Description
The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China's Shang Dynasty. The Zhongqiu Festival
is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest.



The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”,
so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients,
the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours.
She now asks you for help to work out a plan to minimize the cost to fulfill the orders.

 

Input
The input contains no more than 10 test cases.
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens.

The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers.

All the orders are sorted by the time in increasing order.
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the ith line( i starts from 1) contains a integer indicating the cost to make a mooncake during the ith hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1st
hour, Jan 1st 2000 1 o'clock belongs to the 2nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.

 

Output
You should output one line for each test case: the minimum cost.
 

Sample Input
1 10 Jan 1 2000 9 10 5 2 20 20 20 10 10 8 7 9 5 10 0 0
 

Sample Output
70
Hint
“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o'clock , there's a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  4123 4125 4126 4128 4127 
题意:
比较难理解的是题意。一个月饼店只在整点工作。在整点可以制作任意多个月饼。但是在不同的时间制作月饼花费的代价不一样。而且如果一个月饼做好后储存。每小时将花费S。但是储存时间不超过T。现在给你该店工作的最长时间m。和n个订单。问你完成订单的最小花费。
思路:
时间转换成小时。单调队列。维护最优解就行了。有些要注意的地方。
详细见代码:

#include<algorithm>
#include<iostream>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string>
#include<queue>
#include<set>
#include<map>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=100010;
const int days[2][13]=
{
    {0,31,59,90,120,151,181,212,243,273,304,334,365}
    ,{0,31,60,91,121,152,182,213,244,274,305,335,366}
};
map<string,int> mp;
struct node
{
    int r,tm;
} ord[2510];
int q[maxn],head,tail;
int cost[maxn];
bool isLeap(int y)
{
    return (y%400==0)||(y%100!=0&&y%4==0);
}
void mpInit()
{
    mp.clear();
    mp["Jan"]=1;
    mp["Feb"]=2;
    mp["Mar"]=3;
    mp["Apr"]=4;
    mp["May"]=5;
    mp["Jun"]=6;
    mp["Jul"]=7;
    mp["Aug"]=8;
    mp["Sep"]=9;
    mp["Oct"]=10;
    mp["Nov"]=11;
    mp["Dec"]=12;
}
int getHour(string mon,int d,int y,int h)
{
    int i,tm=0;

    for(i=2000;i<y;i++)
        tm+=365+isLeap(i);
    tm+=days[isLeap(y)][mp[mon]-1];
    tm+=d;
    return tm*24+h-23;
}
int main()
{
    mpInit();
    string  mon;
    int y,d,h,T,n,m,i,now;
    __int64 ans,s;

    while((~scanf("%d%d",&n,&m))&&(m||n))
    {
        ans=0;
        for(i=0;i<n;i++)
        {
            cin>>mon;
            scanf("%d%d%d%d",&d,&y,&h,&ord[i].r);
            ord[i].tm=getHour(mon,d,y,h);
        }
        scanf("%d%I64d",&T,&s);
        head=tail=now=0;
        for(i=1;i<=m;i++)//晕死。这里不能写成i<=m&&now<n因为要把cost读完。2B了。。。
        {
            scanf("%d",cost+i);//cost[i]+(ord[now].tm-i)*s<=cost[q[tail-1]]+(ord[now].tm-q[tail-1])*s
            while(head<tail&&cost[i]-i*s<=cost[q[tail-1]]-q[tail-1]*s)//head<tail写前面防RE
                tail--;
            q[tail++]=i;
            while(i==ord[now].tm&&now<n)//这里必须写成while因为有订单时间相同的情况
            {
                while(q[head]<ord[now].tm-T)
                    head++;
                ans+=ord[now].r*(cost[q[head]]+(ord[now].tm-q[head])*s);
                now++;
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.