现在的位置: 首页 > 综合 > 正文

hdu 2128 Frog(简单DP)

2019年04月13日 ⁄ 综合 ⁄ 共 1789字 ⁄ 字号 评论关闭

Frog

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 712    Accepted Submission(s): 338

Problem Description
A little frog named Fog is on his way home. The path's length is N (1 <= N <= 100), and there are many insects along the way. Suppose the

original coordinate of Fog is 0. Fog can stay still or jump forward T units, A <= T <= B. Fog will eat up all the insects wherever he stays, but he will

get tired after K jumps and can not jump any more. The number of insects (always less than 10000) in each position of the path is given.

How many insects can Fog eat at most?
Note that Fog can only jump within the range [0, N), and whenever he jumps, his coordinate increases.
 

Input
The input consists of several test cases.
The first line contains an integer T indicating the number of test cases.
For each test case:
The first line contains four integers N, A, B(1 <= A <= B <= N), K (K >= 1).
The next line contains N integers, describing the number of insects in each position of the path.
 

Output
each test case:
Output one line containing an integer - the maximal number of insects that Fog can eat.
 

Sample Input
1 4 1 2 2 1 2 3 4
 

Sample Output
8
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2110 2191 2175 2177 2180 
 

题意:

长度为N的路上每单位长度上有一定数目的虫子val[i]。现在有一只青蛙开始在位置0处(位置从0到N-1)。它每次能跳的距离在[A,B]范围且它要么往前跳要么不跳。且它最多能跳k次。青蛙每到一个地方都会把那个地方的虫子吃掉。现在告诉你每个地方虫子的个数问你它最多能吃掉多少虫子。

思路:

dp[i][j]表示青蛙到第i个位置时跳了j步所吃的虫子最大数目。那么dp[i][j]=max(dp[i-k][j-1])+val[i]。A<=k<=B.

让后递推就行了。

详细见代码:

#include <iostream>
#include<stdio.h>
using namespace std;
const int INF=0x3f3f3f3f;
int  dp[150][150],val[150];
int main()
{
    int n,k,a,b,lim,i,j,l,t,ans;

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&n,&a,&b,&k);
        for(i=0;i<n;i++)
            scanf("%d",&val[i]);
        ans=dp[0][0]=val[0];
        for(i=1;i<n;i++)
        {
            lim=min(i,k);
            for(j=1;j<=lim;j++)
            {
                dp[i][j]=-INF;
                for(l=a;i-l>=0&&l<=b;l++)//注意范围
                    dp[i][j]=max(dp[i][j],dp[i-l][j-1]+val[i]);
                ans=max(ans,dp[i][j]);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.