现在的位置: 首页 > 算法 > 正文

poj 2184 Cow Exhibition(01背包变形)

2019年04月13日 算法 ⁄ 共 2430字 ⁄ 字号 评论关闭
Cow Exhibition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8273   Accepted: 3047

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for
each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS
and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source

题意:

有n头牛。他们分别有一个聪明值s[i]和幽默值f[i]。现给你这些牛的这两个值。叫你选出一些牛。使得他们的s值总和加上f值总和最大。且都两个总和都非负。

思路:

把s值当容量。f值当价值。dp[i]表示s值和为i时f值的最大值。然后背包就行了。由于有负值。要稍微处理下。

详细见代码:

#include<algorithm>
#include<iostream>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string>
#include<queue>
#include<set>
#include<map>
//#pragma comment(linker,"/STACK:1024000000,1024000000")
using namespace std;
const int INF=0x3f3f3f3f;
const double eps=1e-8;
const double PI=acos(-1.0);
const int maxn=100010;
typedef __int64 ll;
int dp[maxn<<1],s[110],f[110];
int main()
{
    int i,j,n,l,r,ans;

    while(~scanf("%d",&n))
    {
        l=r=maxn;//l,r为上下界
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&s[i],&f[i]);
            if(s[i]<0)//这样处理比较好
                l+=s[i];
            else
                r+=s[i];
        }
        memset(dp,0xcf,sizeof dp);//初始化为无穷大
        dp[maxn]=0;
        for(i=1;i<=n;i++)
        {
            if(s[i]>0)//考虑无后效性。
            {
                for(j=r;j>=s[i]+l;j--)
                    dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
            }
            else
            {
                for(j=l+s[i];j<=r;j++)
                    dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
            }
        }
        ans=0;
        for(i=maxn;i<=r;i++)
            if(dp[i]>=0)
                ans=max(ans,dp[i]+i);
        if(ans>=maxn)
            ans-=maxn;
        printf("%d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.