现在的位置: 首页 > 综合 > 正文

ZOJ1181-多重映射

2019年08月21日 ⁄ 综合 ⁄ 共 2419字 ⁄ 字号 评论关闭

Word Amalgamation


Time Limit: 2 Seconds      Memory Limit: 65536 KB


In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in
the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input

The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line; 
2. a line containing XXXXXX, which signals the end of the dictionary; 
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and 
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in
sorted order, but each word in the dictionary is unique.

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary
words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

要解决
1.一个键值下 多个映射的处理办法(显然map不行,那就用multimap)
2.匹配问题的话,统一把字符串里的字符按字典序排好就好比较了 如:trap 与tarp 统一排好序为:aprt.
3.要按字典序输出。(先把它赋给vector,再用sort快排就ok了)

熟练掌握:
multimap 
1.插入方法:insert(pair<string,string>(s2,s1));
2.得到一个键值下 多个映射的方法:(用上下界)

#include<map>
#include<string>
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
multimap<string,string> v;
int main()
{
	string s1,s2;
	while(cin>>s1)
	{
		if(s1.compare("XXXXXX")==0) break;
		s2=s1;
		sort(s2.begin(),s2.end());
		v.insert(pair<string,string>(s2,s1));
	}
	//sort(v.begin(),v.end());
	multimap<string,string>::iterator itup,itlow;
	while(cin>>s1)
	{
		if(s1.compare("XXXXXX")==0) break;
		sort(s1.begin(),s1.end());
		if(v.find(s1)!=v.end())
		{
			itup=v.upper_bound(s1);           //记住这个得到multimap键值下 上下界的方法. 以便输出(共同键值下)所用映射
			itlow=v.lower_bound(s1);
			vector<string> vec;
			string s1;
			for(;itlow!=itup;itlow++)
			{
			s1=(*itlow).second;
			vec.push_back(s1);
			}
			sort(vec.begin(),vec.end());      //因为multimap 已经用内部排好序.只能输出后再用排序.
			vector<string>::iterator it;
			for(it=vec.begin();it!=vec.end();it++)
			cout<<*it<<endl;
		}
		else cout<<"NOT A VALID WORD"<<endl;
		cout<<"******"<<endl;
	}
	return 0;
	
}

 

抱歉!评论已关闭.