现在的位置: 首页 > 综合 > 正文

HDU1050-贪心-区间重叠

2019年08月21日 ⁄ 综合 ⁄ 共 2246字 ⁄ 字号 评论关闭

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15252    Accepted Submission(s): 5213

Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each
of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the
same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
10 20 30
 

其实这里的区间就是 每两个房间及它们夹的过道(corridor).

别人的代码:

#include<stdio.h>   
#include<string.h>   
const int maxn = 210;  
int corridor[maxn];  
inline void swap(int &a, int &b)  
{  
    int t = a;  
    a = b;  
    b = t;  
}  
int main()  
{  
    int test;  
    scanf("%d", &test);  
    while(test--)  
    {  
        int n;  
        scanf("%d", &n);  
       memset(corridor, 0, sizeof(corridor));  
          
        int min = 0;  
        int a, b;  
        for(int i =1; i <=n; i++)  
        {  
            scanf("%d%d", &a, &b);  
              
            //注意房间是对称分布的,即1~3房间和2~4房间是重叠的    
            a = (a-1)/2;                                    //小技巧:最重要的是把两个房间捆绑起来,即得到了每个过道的编号!!!!!
            b = (b-1)/2;  
              
            //题目要求是从房间a搬至房间b,但没有要求房间a的编号一定要小于房间b的编号    
            if(a > b)  
                swap(a, b);  
            for(int i = a; i <= b; i++)  
            {  
                corridor[i]++;  
                if(min < corridor[i])  
                    min = corridor[i];  
            }  
        }  
          
        printf("%d\n", min * 10);  
    }  
      
    return 0;  
}  

 

抱歉!评论已关闭.