现在的位置: 首页 > 综合 > 正文

hdu 4927 Series 1 递推+大数

2019年09月04日 ⁄ 综合 ⁄ 共 1432字 ⁄ 字号 评论关闭

Series 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Let A be an integral series {A1, A2, . . . , An}. The zero-order series of A is A itself. The first-order series of A is {B1, B2, . . . , Bn-1},where Bi = Ai+1 - Ai. The ith-order series of A is the first-order series of its (i - 1)th-order series (2<=i<=n - 1). Obviously, the (n - 1)th-order series of A is a single integer. Given A, figure out that integer.
 


Input
The input consists of several test cases. The first line of input gives the number of test cases T (T<=10). For each test case: The first line contains a single integer n(1<=n<=3000), which denotes the length of series A. The second line consists of n integers, describing A1, A2, . . . , An. (0<=Ai<=105)
 


Output
For each test case, output the required integer in a line.
 


Sample Input
2 3 1 2 3 4 1 5 7 2
 


Sample Output
0 -5
 

import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main{
		public static void main(String arg[]){
		final int MAXN=3000+100;
		Scanner cin=new Scanner(System.in);
		BigInteger[] a=new BigInteger[MAXN];
		BigInteger[] c=new BigInteger[MAXN];
		int T;
		T=cin.nextInt(); 
		while(T>0){
			T--;
			int n;
			n=cin.nextInt();
			c[0]=BigInteger.ONE;
			for(int i=1;i<=n;i++){
				c[i]=(c[i-1].multiply(BigInteger.valueOf(n-i)));
				c[i]=c[i].divide(BigInteger.valueOf(i));
			}
			for(int i=1;i<=n;i++){
				a[i]=cin.nextBigInteger();
			}
			BigInteger ans=BigInteger.ZERO;
			for(int i=1;i<=n;i++){
				if(i%2 == 1)
					ans=ans.add(c[i-1].multiply(a[n+1-i]));
				else 
					ans=ans.subtract(c[i-1].multiply(a[n+1-i]));
			}
			System.out.println(ans);
		}
	}
};

抱歉!评论已关闭.