现在的位置: 首页 > 综合 > 正文

杭电 1718

2019年09月07日 ⁄ 综合 ⁄ 共 1287字 ⁄ 字号 评论关闭

Rank

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2875    Accepted Submission(s): 1093

Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the
second best mark(or is tied) his rank is 2, and so on.

Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000
and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.

Output
For each test case, output a line giving Jackson’s rank in the class.

Sample Input
20070101 20070102 100 20070101 33 20070103 22 20070106 33 0 0

Sample Output
2
#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;

int cmp(int a, int b)
{
	return a>=b;  //从大到小排序
}
int main()
{		
	int num[100],i, flag;
	string str1, str2;
	while (cin>>str1) //输入参照数组
	{
	    for(i=0; ;i++)
		{
			cin>>str2>>num[i]; 
			if (str2=="0"&&num[i]==0)
				break;
			if (str1==str2)
				flag = num[i];  //记录分数
		}
		sort(num, num+i, cmp);
		for (int j=0; j<i; j++)
			if (num[j]==flag) //如果和记录的分数相同
			{
				cout<<j+1<<endl; //数组从0开始排序,输出时序号加一
				break;
			}
	}
	return 0;
}

抱歉!评论已关闭.