现在的位置: 首页 > 综合 > 正文

hdu5119Happy Matt Friends

2019年11月06日 ⁄ 综合 ⁄ 共 1833字 ⁄ 字号 评论关闭

Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)
Total Submission(s): 700    Accepted Submission(s): 270

Problem Description
Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.

 

Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.

 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
 

Sample Input
2 3 2 1 2 3 3 3 1 2 3
 

Sample Output
Case #1: 4 Case #2: 2
Hint
In the first sample, Matt can win by selecting: friend with number 1 and friend with number 2. The xor sum is 3. friend with number 1 and friend with number 3. The xor sum is 2. friend with number 2. The xor sum is 2. friend with number 3. The xor sum is 3. Hence, the answer is 4.
 

Source
2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

题意:有N个人,每个人有一个权值,你可以挑任意多的人并将他们的权值异或(也可以不选),求最后得到的值不小于M的取法有多少种。

dp[i][j]:在前i个人里挑选,取法结果为j的方法有多少种
dp[i][j]=dp[i-1][j^val[i]]+dp[i-1][j]

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
using namespace std;
long long dp[2][1<<20];
int val[50];
int main()
{
    int T;
    cin>>T;
    for(int cs=1;cs<=T;cs++)
    {
        int n,m;
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            cin>>val[i];
        int len=1<<20;
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=1;i<=n;i++)
            for(int j=0;j<len;j++)
                dp[i&1][j]=dp[(i-1)&1][j]+dp[(i-1)&1][j^val[i]];
        long long ans=0;
        for(int i=m;i<len;i++)
            ans+=dp[n&1][i];
        printf("Case #%d: %lld\n",cs,ans);
    }
}
【上篇】
【下篇】

抱歉!评论已关闭.