现在的位置: 首页 > 综合 > 正文

poj 1157 LITTLE SHOP OF FLOWERS

2012年11月21日 ⁄ 综合 ⁄ 共 2914字 ⁄ 字号 评论关闭

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.
  

 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

7 23 -5 -24 16

2 (begonias)

5 21 -4 10 23

3 (carnations)

-21

5 -4 -20 20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

  • The first line contains two numbers: F, V.        
  • The following F lines: Each of these lines contains V         integers, so that Aij is given as the         jth number on the (i+1)st         line of the input file.

  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
  • F <= V <= 100 where V is the number of vases.
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5 7 23 -5 -24 16 5 21 -4 10 23 -21 5 -4 -20 20

Sample Output

53

题意:
    f朵花放到v个瓶子里,每朵花放到每个瓶子都有相应的观赏值,一个瓶子只能放一朵花,求最大的观赏值。

    用dp[i][j]表示i朵花放到j个瓶子里所得到的最大观赏值,可得状态转移方程:
        dp[i][j] = dp[i][j-1]>dp[i-1][j-1]+a[i][j]?dp[i][j-1]:dp[i-1][j-1]+a[i][j] ;

代码:
#include<iostream>
#include<cstring>
using namespace std ;

int main(){
    int f, v, i, j ;
    int a[110][110] ;
    int dp[110][110] ;
    while(cin >> f >> v){
        for(i=1; i<=f; i++)
            for(j=1; j<=v; j++)
                cin >> a[i][j] ;
        memset(dp, 0, sizeof(dp)) ;
        dp[1][1] = a[1][1] ;
        for(i=2; i<=f; i++)
            dp[1][i] = dp[1][i-1]>a[1][i]?dp[1][i-1]:a[1][i] ;
        for(i=1; i<=f; i++){
            dp[i][i] = dp[i-1][i-1] + a[i][i] ;
            for(j=i+1; j<=v; j++)
                dp[i][j] = dp[i][j-1]>dp[i-1][j-1]+a[i][j]?dp[i][j-1]:dp[i-1][j-1]+a[i][j] ;
        }
        cout << dp[f][v] << endl ;
    }
    return 0 ;
}

抱歉!评论已关闭.