现在的位置: 首页 > 综合 > 正文

Leftmost Digit(解题报告)

2012年08月10日 ⁄ 综合 ⁄ 共 1287字 ⁄ 字号 评论关闭

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 364 Accepted Submission(s): 198
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2
Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

题目大意是输入N,求N^N的最高位数字。1<=N<=1,000,000,000

估计大家看到N的范围就没想法了。确实N的数字太大,如果想算出结果,即使不溢出也会超时。

这题我纠结了很久。在同学的提示下ac了。

题目是这样转化的。

首先用科学计数法来表示                    N^N  = a*10^x;    比如N = 3;  3^3 = 2.7 * 10^1;

我们要求的最右边的数字就是(int)a,即a的整数部分;

OK, 然后两边同时取以10为底的对数     lg(N^N) = lg(a*10^x) ;

化简                                             N*lg(N)  = lg(a) + x;

继续化                                          N*lg(N) - x = lg(a)

                                                  a = 10^(N*lg(N) - x);

现在就只有x是未知的了,如果能用n来表示x的话,这题就解出来了。

又因为,x是N^N的位数。比如 N^N = 1200  ==>  x = 3;    实际上就是 x 就是 lg(N^N) 向下取整数,表示为[lg(N^N)]

ok       a = 10^(N*lg(N) - [lg(N^N)]);    然后(int)a 就是答案了。

代码:

#include<iostream>
#include<math.h>
int main()
{
	int n,m;
	std::cin>>n;
	while(n--)
	{
		std::cin>>m;
		long double t = m*log10(m*1.0);
		t -= (__int64)t;
		__int64 ans = pow((long double)10, t);
		std::cout<<ans<<std::endl;
	}
	return 0;
}

抱歉!评论已关闭.