现在的位置: 首页 > 综合 > 正文

SDUT——K-based Numbers

2013年03月06日 ⁄ 综合 ⁄ 共 732字 ⁄ 字号 评论关闭

原题:

题目描述

Let’s consider K-based numbers, containing exactly N digits. We define a number to be valid if its K-based notation doesn’t contain two successive zeros. For example:
(1)1010230 is a valid 7-digit number;

(2)1000198 is not a valid number;

(3)0001235 is not a 7-digit number, it is a 4-digit number.

Given two numbers N and K, you are to calculate an amount of valid K based numbers, containing N digits.

You may assume that 2 ≤ K ≤ 10; N ≥ 2; N + K ≤ 18.

输入

The numbers N and K in decimal notation separated by the line break.

输出

The result in decimal notation.

示例输入

2 10

示例输出

90

 

分析:

递推,哎呀,如果我自己递推,肯定哇。

原码;

#include <iostream>
using namespace std;
const int maxn=20;
long long f[maxn],n,k;
int main()
{

    while(cin>>n>>k)
    {
        if(n==1)
        {
            cout<<k<<endl;
            return 0;
        }
        f[1]=k-1;
        f[2]=k*(k-1);
        for( int i=3; i<=n; i++)
        {
            f[i]=(f[i-1]+f[i-2])*(k-1);
        }
        cout<<f[n]<<endl;
    }
    return 0;
}

 

 

抱歉!评论已关闭.