现在的位置: 首页 > 综合 > 正文

1154. Easy sort

2012年08月07日 ⁄ 综合 ⁄ 共 1027字 ⁄ 字号 评论关闭

1154. Easy sort

Description

You know sorting is very important. And this easy problem is:

Given you an array with N non-negative integers which are smaller than 10,000,000, you have to sort this array. Sorting means that integer with smaller value presents first.

Input

The first line of the input is a positive integer T. T is the number of the test cases followed.

The first line of each test case is a positive integer N (1<= N<= 1000) which represents the number of integers in the array. After that, N lines followed. The i-th line is the i-th integer in the array.

Output

The output of each test case should consist of N lines. The i-th line is the i-th integer of the array after sorting. No redundant spaces are needed.

Sample Input

2312311

Sample Output

1231

Problem Source

ZSUACM Team Member

// source code of submission 912268, Zhongshan University Online Judge System
#include<iostream>
using namespace std;
int main()
{
    int i,j,k;
    int T;
    int c;
    cin >> T;
    int m[1000];
    for (i = 0; i < T; i++)
    {
        cin >> c;
        for (int i = 0; i < c; i++)
        {
            cin >> m[i];
        }
        for (j = 1; j < c; j++)
        {
            int currentElement = m[j];
            for (k = j - 1; k >= 0 && m[k] > currentElement; k--)
            {
                m[k + 1] = m[k];
            }
            m[k + 1] = currentElement;
        }
        for (j = 0; j < c; j++)
        {
            cout << m[j] << endl;
        }
    }
    return 0;
}

抱歉!评论已关闭.