现在的位置: 首页 > 综合 > 正文

poj 2485 Highways

2012年04月21日 ⁄ 综合 ⁄ 共 2005字 ⁄ 字号 评论关闭

这是一道典型的最小生成树的题目,给的是每个城市之间的距离,然后求最小生成树中的最小的边、、、用pirme加一点改正就可以很水的过掉啊、、、

声明一点我是听我同学说的,然后拿刘汝佳的dijkstra改写的,不得不说他的代码真的是很简约啊、、膜拜啊、、、

Highways
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18808   Accepted: 8723

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible
to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#define N 510
#define oo 1 << 30

using namespace std;

int map[N][N], d[N], n;
bool v[N];

int prim()
{
    int max = 0;
    memset(v , false , sizeof(v));
    for(int i = 0; i < n; i++) d[i] = map[0][i];
    d[0] = 0;
    v[0] = true;
    for(int i = 0; i < n-1; i++)
    {
        int x, m = oo;
        for(int y = 0; y < n; y++) if(!v[y] && d[y]<=m) m = d[x=y];
        v[x] = true;
        if(max < m) max = m;
        for(int y = 0; y < n; y++) if(!v[y] && d[y] > map[x][y]) d[y] = map[x][y];
    }
    return max;
}

int main()
{
    int t, i, j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i = 0; i < n; i++)
            for(j = 0; j < n; j++)
                scanf("%d",&map[i][j]);
        printf("%d\n",prim());
    }
    return 0;
}

抱歉!评论已关闭.