现在的位置: 首页 > 综合 > 正文

hdu 2955(DP背包问题)

2013年03月30日 ⁄ 综合 ⁄ 共 2329字 ⁄ 字号 评论关闭

DP背包问题(关于抢银行成功概率) 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2955

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4778    Accepted Submission(s): 1808


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before
retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 


Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line
j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 


Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

 


Sample Input
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 


Sample Output
2 4 6
 


//用dp[i]表示偷价值为i时不被抓的概率,则状态转移方程为:dp[i]=max(dp[i],dp[i-m]*(1-p));
//AC 78ms 332k(by C) 62ms 360k(by C++)
#include<stdio.h>
#include<string.h>
double dp[10005];          //因为n的最大值为100,mj的最大值也为100,所以数组要开得比10000大
int main()
{
	int test;               //测试数据组数
	double p,pj[105];  //p表示总共不能超过的被抓概率,pj表示抢劫相应的银行被抓的概率,注意:抢劫各个银行被抓的概率相互独立
	int n,mj[105];     //n表示此次可抢劫的银行数,mj表示从相应的银行能抢到的钱
	int i,j,sum;           //sum记录钱
	scanf("%d",&test);
	while(test--)
	{
		sum=0;
		memset(dp,0,sizeof(dp));
		dp[0]=1;           //dp的下表即抢的钱数,他的值,表示抢劫相应的钱后,逃跑的概率,还未抢劫时:钱为0,逃跑的概率为1
		scanf("%lf%d",&p,&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%lf",&mj[i],&pj[i]);
			sum+=mj[i];
		}
		for(i=0;i<n;i++)
			for(j=sum;j>=mj[i];j--)
			{
				if(dp[j]<(dp[j-mj[i]]*(1-pj[i])))//状态转移方程,由各个概率相互独立所得
					dp[j]=dp[j-mj[i]]*(1-pj[i]);
//在总的抢劫价值都是j的情况下,如果抢劫第i个银行了,不被抓的概率大于原来没有抢第i个银行的概率的情况下,就dp[j]=dp[j-mj[i]]*(1-pj[i]);表示抢劫第i个银行,否则查找下一个银行。
			}
		for(i=sum;i>=0;i--)
			if(dp[i]>=(1-p))
			{
				printf("%d\n",i);
				break;
			}
	}
	return 0;
}

抱歉!评论已关闭.