现在的位置: 首页 > 综合 > 正文

HDU 4252 A Famous City 解题报告

2012年01月04日 ⁄ 综合 ⁄ 共 1877字 ⁄ 字号 评论关闭

A Famous City

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 472    Accepted Submission(s): 190


Problem Description
After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows:
- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building,
or no buildings at all.
- measure the height of each building in that piece.
- write a program to calculate the minimum number of buildings.
Mr. B has finished the first two steps, the last comes to you.
 


Input
Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the
input numbers will be nonnegative and less than 1,000,000,000.
 


Output
For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.
 


Sample Input
3 1 2 3 3 1 2 1
 


Sample Output
Case 1: 3 Case 2: 2
Hint
The possible configurations of the samples are illustrated below:

首先我想吐槽下这题目的给的测试数据,乍一看还以为求最大值(昨天比赛时就有人这么写)。 原本我以为是一栋房子可以在多张图片中出现,所以是先排序,在求不同层数的房子。接连wa两次! 得出一个结论,以后尽量看点点英语

题目原意是一栋房子可以接连出现在连续的几张照片中,给出的数字只代表这张照片中最高的楼。例如这两组数据:

5

1 2 1 2 1

10

1 2 3 4 5 4 3 2 1 0

的答案分别是3和5。第一组的三个1,可能是一栋一层的房子跨越了五张照片。而两个2一定代表两栋房子,因为中间的“1”。

题意知道后,这题就不难了!AC代码如下

#include<stdio.h>
#include<string.h>
int a[100005];
bool flag[100005];
int main()
{
   int n,i,j,s=1;
   while(scanf("%d",&n)!=EOF)
   {
		int ans=0;
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		memset(flag,0,sizeof(flag));
		for(i=0;i<n;i++)
		{
			if(a[i]==0) {flag[i]=1;continue;}
			int t=a[i];
			if(!flag[i])
				for(j=i+1;;j++)
				{
					if(a[j]==t) flag[j]=1;
					else if(a[j]<t) break;
				}
		}
		for(i=0;i<n;i++)
			if(!flag[i]) ans++;
			printf("Case %d: %d\n",s++,ans);
   }
   return 0;
}

抱歉!评论已关闭.