现在的位置: 首页 > 综合 > 正文

bit 1038 Red and Black

2013年07月16日 ⁄ 综合 ⁄ 共 2385字 ⁄ 字号 评论关闭

Red and Black

时间限制: 1秒  内存限制: 64M

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent
tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively.
W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set) The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45 59 6 13

Source

http://acm.pku.edu.cn/JudgeOnline/problem?id=1979

简单的bfs,最不地道的是给的例子就一次换行,judge时按每一个结果都换,害的我提交几次,都wa

#include<stdio.h>

typedef struct Q{
	int x,y;
}Queue;

Queue result[1000];
int tail,head;
int W,H;

void bfs(int input_rec_map[][30],int x,int y){
	int dir[2] ={1,-1};
	int i;
	if(head == tail){
		return ;
	}

	for(i = 0; i < 2;++i){
		if((x+dir[i] > -1) && (x+dir[i] < W) && input_rec_map[y][x+ dir[i]] ){
			input_rec_map[y][x+ dir[i]] = 0;
			result[tail].x = x + dir[i];
			result[tail].y = y;
			++tail;
		}
	}

	for(i = 0; i < 2;++i){
		if((y + dir[i] > -1) && (y + dir[i] < H) &&(input_rec_map[y+dir[i]][x])){
			input_rec_map[y+dir[i]][x] = 0;
			result[tail].x = x;
			result[tail].y = y + dir[i];
			++tail;
		}
	}
	++head;
	bfs(input_rec_map,result[head].x,result[head].y);

}

int main(){
	char input_rec[30][30];     
	int input_rec_map[30][30];
	int i,j;
	//int than_one = 0;

	//FILE *fp;
	//fp = freopen("in.txt","r",stdin);
	while(~scanf("%d%d",&W,&H),W||H){
		for(i = 0;i < H; ++i){
			scanf("%s",input_rec[i]);
		}
		for(i = 0; i < H; ++i){
			for(j = 0;j<W;++j){
				if(input_rec[i][j] == '.'){
					input_rec_map[i][j] = 1;
				}else if(input_rec[i][j] == '#'){
					input_rec_map[i][j] = 0;
				}else{
					result[0].x = j;
					result[0].y = i;
					input_rec_map[i][j] = 0;
				    head = 0;
					tail = 1;
				}
			}	
		}
		bfs(input_rec_map,result[0].x,result[0].y);
	
		//if(than_one){
		//	printf(" %d",head);
		//}else{
			printf("%d\n",head);
		//}
		//than_one = 1;
	}
	//printf("\n");
	return 0;
}

抱歉!评论已关闭.