现在的位置: 首页 > 综合 > 正文

hdu 2923 Einbahnstrasse

2012年07月30日 ⁄ 综合 ⁄ 共 4303字 ⁄ 字号 评论关闭

Einbahnstrasse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1400    Accepted Submission(s): 389

Problem Description
Einbahnstra e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate
a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan
their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the
shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls
from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in
to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.

 

Input
Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's
garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations
of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:

A -v -> B
A <-v - B
A <-v -> B

A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the
last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.

 

Output
For each test case, print the total distance traveled using the following format:

k . V

Where k is test case number (starting at 1,) is a space, and V is the result.

 

Sample Input
4 2 5 NewTroy Midvale Metrodale NewTroy <-20-> Midvale Midvale --50-> Bakerline NewTroy <-5-- Bakerline Metrodale <-30-> NewTroy Metrodale --5-> Bakerline 0 0 0
 

Sample Output
1. 80
 

Source
 

Recommend
lcy
 

题目就是算。你找到一份新工作就是把烂车运回公司。问你完成一天工作后所走的最短路程是多少。

题目不难。关键是输入数据不好处理。

#include <stdio.h>
#include<string.h>
__int64 dis[150][150];
__int64 INF=111111111111;//貌似数据很大于是用int64了。不过同学用int还是过了
int n,sum;
char city[110][20];
void floyd()
{
    int k,i,j;
    for(k=0; k<n; k++)
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                if(dis[i][k]+dis[k][j]<dis[i][j])
                    dis[i][j]=dis[i][k]+dis[k][j];
}
int getp(char *c)//建立地点名字和地点号的映射。接收地点名返回地点号
//有利于数据处理
{
    int i;
    for(i=0; i<sum; i++)
    {
        if(strcmp(c,city[i])==0)
            return i;
    }
    strcpy(city[i],c);
    sum++;
    return i;
}
int main()
{
    int a,b,c,r,i,j,left,right,wait[1010];//wait记录烂车所在的地点号
    __int64 d,alld;//d记录两地点路的长度.记录当天总距离
    char s[20],e[20],op[10],w[20];//s记录开始城市名.e记录结束城市名.op记录剪头
                                  //和距离。

    while(scanf("%d%d%d",&n,&c,&r),n||c||r)
    {
        t++;//记录测试数
        getchar();
        sum=0;
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
            {
                if(i==j)
                    dis[i][j]=0;
                else
                    dis[i][j]=INF;
            }
        for(i=0; i<c+1; i++)
        {
            scanf("%s",w);
            wait[i]=getp(w);
        }
        for(i=0; i<r; i++)
        {
            scanf("%s%s%s",s,op,e);
            a=getp(s);
            d=0;
            left=right=0;
            for(j=0; op[j]!='\0'; j++)//记录道路类型(单双行道)
            {
                if(op[j]=='<')
                    left=1;//左边通
                if(op[j]=='>')
                    right=1;//右边通
                if(op[j]>='0'&&op[j]<='9')
                    d=d*10+op[j]-'0';//算出道路长度
            }
            b=getp(e);
            if(left&&d<dis[b][a])
                dis[b][a]=d;
            if(right&&d<dis[a][b])
                dis[a][b]=d;
            //printf("%d -> %d is %I64d\n",a,b,dis[a][b]);
            //printf("%d -> %d is %I64d\n",b,a,dis[b][a]);
        }
        floyd();
        //for(i=0; i<n; i++)
        //for(j=0; j<n; j++)
        //printf("%d -> %d is %I64d\n",i,j,dis[i][j]);
        alld=0;
        for(i=1; i<=c; i++)//每次从公司出发只能处理一辆烂车后必须先回公司
        {
            alld=alld+dis[wait[0]][wait[i]]+dis[wait[i]][wait[0]];
        }
        printf("%d. %I64d\n",t,alld);
    }
    return 0;
}
/*
4 2 5
NewTroy Midvale Metrodale
NewTroy   <-20-> Midvale
Midvale   --50-> Bakerline
NewTroy    <-5-- Bakerline
Metrodale <-30-> NewTroy
Metrodale  --5-> Bakerline
*/

抱歉!评论已关闭.