现在的位置: 首页 > 综合 > 正文

hdu 1087 Super Jumping! Jumping! Jumping! ( 求序列的最大上升序列 )

2012年10月22日 ⁄ 综合 ⁄ 共 1984字 ⁄ 字号 评论关闭

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17746 Accepted Submission(s): 7617

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0

Sample Output
4 10 3

Author
lcy
题意:求序列的最大上升序列,(可跳)不用连续。
分析:开另一个数组b来保存同下标的“最大值”,每一个都要向前找合法的最大b值。

感想:最近在刷dp啊dp....从水题开始感悟啊感悟~~~~~~~~

代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

int a[1001],b[1001];

int main()
{
    int n,i,j;
    while(scanf("%d",&n)&&n)
    {
        memset(b,0,sizeof(b));
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(i=1;i<=n;i++)
        {
            int maxb=0;
            b[i]=a[i];
            for(j=1;j<=n;j++)
            {
                if(a[j]<a[i])
                {
                    maxb=max(maxb,b[j]);
                    //printf("test:%d %d \n",j,maxb);
                }
            }
            b[i]+=maxb;
        }
        int sum=0;
        for(i=1;i<=n;i++)
            sum=max(sum,b[i]);
        printf("%d\n",sum);
    }
    return 0;
}

抱歉!评论已关闭.