现在的位置: 首页 > 综合 > 正文

1797 Vito’s family

2012年01月06日 ⁄ 综合 ⁄ 共 1135字 ⁄ 字号 评论关闭

 

描述

Background

The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.

Problem

Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.

输入

The input consists of several test cases. The first line contains the number of test cases.

For each test case you will be given the integer number of relatives r ( 0 <
r < 500) and the street numbers (also integers) s0, s1, ..., si, ..., sr where they live ( 0 <
si < 30000 ). Note that several relatives could live in the same street number.

输出

For each test case your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers
si and sj is dij= |si-sj|.

样例输入
2
2 2 4
3 2 4 6
样例输出
2
4

模拟题

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
              cin>>n;
              int a[n];
              int min,max;
              for(int i=0;i<n;i++)
              {      cin>>a[i];
                    if( i==0 )
                    {  min=a[0]; max=a[0]; }
                    else{
                           if( min> a[i] )
                           min=a[i];
                           
                           if( max<a[i] )
                           max=a[i];
                         }
              }
             
              
              double g=(min+max)/2;
              double sum=0;
              for( int i=0;i<n;i++)
               sum+=fabs( a[i]-g );
               
              cout<<sum<<endl;
    }
    return 0;
}

 

抱歉!评论已关闭.