现在的位置: 首页 > 综合 > 正文

1039. Course List for Student (25)-PAT

2012年06月06日 ⁄ 综合 ⁄ 共 3508字 ⁄ 字号 评论关闭

1039. Course List for Student (25)

时间限制
200 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the
courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student
names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing
order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

推荐指数:※※

来源:http://pat.zju.edu.cn/contests/pat-a-practise/1039

这道题首先想到使用map(最后一个case木有通过,超时,改用hash_map,竟然编译器不支持。。。),后来,参见了@sunbaigui的博客,对名字使用hash,直接上vector,通过。

#include<iostream>
#include<vector>
#include<algorithm>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
const int N=26*26*26*10;
bool compare(int a,int b){
	return a<b;
}
int hash_name(char *name){
	return (name[0]-'A')*26*26*10+(name[1]-'A')*26*10+(name[2]-'A')*10+(name[3]-'0');
}
int main(){
	int n,k;
	scanf("%d%d",&n,&k);
	int i,j;
	vector< vector<int> > stu(N+1);
	for(i=0;i<k;i++){
		int course,stu_num;
		scanf("%d%d",&course,&stu_num);
		for(j=0;j<stu_num;j++){
			char str[5];
			scanf("%s",str);
			stu[hash_name(str)].push_back(course);
		}
	}
	for(i=0;i<n;i++)
	{
		char str[5];
		scanf("%s",str);
		if(stu[hash_name(str)].size()!=0){
			printf("%s %d",str,stu[hash_name(str)].size());
			sort(stu[hash_name(str)].begin(),stu[hash_name(str)].end(),compare);
			vector<int>::iterator iter_vec;
			for(iter_vec=stu[hash_name(str)].begin();iter_vec!=stu[hash_name(str)].end();iter_vec++){
				printf(" %d",*iter_vec);
			}
			printf("\n");
		}
		else
			printf("%s %d\n",str,0);
	}
	return 0;
}

map的版本(最后一个case超时):

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<string>
using namespace std;
bool compare(int a,int b){
	return a<b;
}
int main(){
	int n,k;
	scanf("%d%d",&n,&k);
	int i,j;
	map< string,vector<int> > map_cour;
	for(i=0;i<k;i++){
		int course,stu_num;
		scanf("%d%d",&course,&stu_num);
		for(j=0;j<stu_num;j++){
			char str[5];
			scanf("%s",str);
			string stu_name=string(str);
			map_cour[stu_name].push_back(course);
		}
	}
	for(i=0;i<n;i++)
	{
		char str[5];
		scanf("%s",str);
		string stu_name=string(str);
		map<string,vector<int> >::iterator iter;
		iter=map_cour.find(stu_name);
		if(iter!=map_cour.end()){
			vector<int>:: iterator iter_vec;
			printf("%s %d",stu_name.c_str(),map_cour[stu_name].size());
			sort(map_cour[stu_name].begin(),map_cour[stu_name].end(),compare);
			for(iter_vec=map_cour[stu_name].begin();iter_vec!=map_cour[stu_name].end();iter_vec++){
				printf(" %d",*iter_vec);
			}
			printf("\n");
		}
		else
			printf("%s %d\n",stu_name.c_str(),0);
	}
	return 0;
}

抱歉!评论已关闭.