现在的位置: 首页 > 综合 > 正文

UVa 10110 – Light, more light

2012年06月01日 ⁄ 综合 ⁄ 共 1468字 ⁄ 字号 评论关闭

UVa 10110 - Light, more light

Table of Contents

1 题目

===================

Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns
on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches
whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off? 
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

The Output

Output "yes" if the light is on otherwise "no"
, in a single line.

Sample Input

3
6241
8191
0

Sample Output

no
yes
no

Sadi Khan 
Suman Mahbub 
01-04-2001

===================

2 思路

这题关键是理解题目的意思,抽象成数学问题就是1~n中n的因子个数是奇数还是偶数,由于因子都是 成对出现的,所以问题其实就是在问n是否是完全平方数。

3 代码

/*
 * Problem: UVa 10110 - Light, more light
 * Lang: ANSI C
 * Time: 0.029
 * Author: minix
 */


#include <stdio.h>
#include <math.h>

int main() {
  long long n, qn;

  while (scanf ("%lld", &n) != EOF) {
    if (n == 0) break;

    qn = (long long)sqrt(n);

    if (qn*qn == n) printf ("yes\n");
    else printf ("no\n");
  }

  return 0;
}

抱歉!评论已关闭.