现在的位置: 首页 > 综合 > 正文

poj 1422 二分图最小路径覆盖

2013年08月17日 ⁄ 综合 ⁄ 共 2598字 ⁄ 字号 评论关闭

        二分图最小路径覆盖==点数n--二分图最大匹配,,,知道了这个公式,,又是一道水题。。。二分图方面的题,,关键是建图,把图建好了,剩下的就简单了。。。题目:

Air Raid
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 4600   Accepted: 2722

Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets
form no cycles. 

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper
lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper. 

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format: 

no_of_intersections 
no_of_streets 
S1 E1 
S2 E2 
...... 
Sno_of_streets Eno_of_streets 

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets
in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk
<= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections. 

There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town. 

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

ac代码:

#include <iostream>
#include <algorithm>
#include <string.h>
#include <vector>
#include <cstdio>
using namespace std;
vector<int> ss[125];
int flag[125],visted[125];
bool dfs(int x){
	for(int i=0;i<ss[x].size();++i){
		if(!visted[ss[x][i]]){
		  visted[ss[x][i]]=1;
		  if(flag[ss[x][i]]==-1||dfs(flag[ss[x][i]])){
		    flag[ss[x][i]]=x;
			return true;
		  }
		}
	}
	return false;
}
int main(){
  int kk;
  scanf("%d",&kk);
  while(kk--){
    int n,m;
	scanf("%d%d",&n,&m);
	memset(ss,0,sizeof(ss));
	memset(flag,-1,sizeof(flag));
	int x,y;
	while(m--){
	  scanf("%d%d",&x,&y);
	  ss[x].push_back(y);
	}
	int sum=0;
	for(int i=1;i<=n;++i){
	  memset(visted,0,sizeof(visted));
	  if(dfs(i))
		  sum++;
	}
	printf("%d\n",n-sum);
  }
  return 0;
}

抱歉!评论已关闭.