现在的位置: 首页 > 综合 > 正文

动态规划 杭电 1087

2013年08月11日 ⁄ 综合 ⁄ 共 1987字 ⁄ 字号 评论关闭

        刚把纠结了一上午的一道DP题写出来,这次终于碰到个软柿子,一次水过,,水题。题目:

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10323    Accepted Submission(s): 4252


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

 


Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 


Output
For each case, print the maximum according to rules, and one line one case.
 


Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 


Sample Output
4 10 3
 

ac代码:

#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
int main(){
	//freopen("4.txt","r",stdin);
  int n,num[1005],dp[1005];
  while(scanf("%d",&n)&&n){
    for(int i=1;i<=n;++i)
		scanf("%d",&num[i]);
	memset(dp,0,sizeof(dp));
	dp[1]=num[1];
	int xmax;
	for(int i=2;i<=n;++i){
		xmax=0;
		for(int j=1;j<i;++j){
			if(num[j]<num[i]){
			  if(dp[j]>xmax)
				  xmax=dp[j];
			}
		}
		if(xmax==0)
			dp[i]=num[i];
		else
			dp[i]=xmax+num[i];
	}
	xmax=0;
	for(int i=1;i<=n;++i)
		if(xmax<dp[i])
			xmax=dp[i];
	printf("%d\n",xmax);
  }
  return 0;
}

抱歉!评论已关闭.