现在的位置: 首页 > 综合 > 正文

poj3436 ACM Computer Factory 拆点+网络流

2013年08月09日 ⁄ 综合 ⁄ 共 4346字 ⁄ 字号 评论关闭
ACM Computer Factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4674 Accepted: 1582 Special Judge

Description

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using
N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance
(measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of
P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of
P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange
production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers
P N
, then N descriptions of the machines. The description of ith machine is represented as by 2
P + 1 integers Qi Si,1Si,2...Si,PDi,1Di,2...Di,P, where
Qi specifies performance, Si,j — input specification for part
j, Di,k — output specification for part
k.

Constraints

1 ≤ P ≤ 10, 1 ≤
N
≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then
M — number of connections that must be made, then M descriptions of the connections. Each connection between machines
A and B must be described by three positive numbers A B W, where
W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0
 
    由于该题是节点流量限制,所以应该把每个点拆成两个点,从而转化成边流量限制。
建图:将每台机器看做一个节点,然后把每个节点拆成两个(i和i+n),建边i->i+n,边流量限制为该机器的速度;对于每台机器i,若s[j]=0||s[j]=2,则建边s->i,边流量限制为INF,若d[j]=1,则建边i+n->t,边流量限制为INF;然后枚举所有的机器对(i,j),若符合要求则建边i+n->j,边流量限制为INF。
    然后就可以求最大流了,最后输出所有流量大于0的边以及流量。
 
#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;
const int MAXN=55;
const int INF=(1<<29);
struct
{
    int q;
    int s[10],d[10];
}machine[MAXN];
struct Arc
{
    int c,f;
};
Arc flow[MAXN*2][MAXN*2];
int level[MAXN*2];
int p,n,s,t;

int bfs()
{
    int queue[MAXN*2],front,rear;
    front=rear=0;
    memset(level,0,sizeof(level));
    level[s]=1;
    queue[rear++]=s;
    while(front!=rear)
    {
        int v=queue[front++];
        for(int i=0;i<=t;i++)
        {
            if(!level[i]&&flow[v][i].f<flow[v][i].c)
            {
                level[i]=level[v]+1;
                queue[rear++]=i;
            }
        }
    }
    return level[t];
}

int dfs(int i,int f)
{
    if(i==t)
        return f;
    int sum=0;
    for(int j=0;f&&j<=t;j++)
    {
        if(level[j]==level[i]+1&&flow[i][j].f<flow[i][j].c)
        {
            int tmp=dfs(j,min(f,flow[i][j].c-flow[i][j].f));
            sum+=tmp;
            f-=tmp;
            flow[i][j].f+=tmp;
            flow[j][i].f-=tmp;
        }
    }
    return sum;
}

int dinic()
{
    int maxflow=0;
    while(bfs())
        maxflow+=dfs(s,INF);
    return maxflow;
}

int main()
{
    int i,j,k;
    int maxflow,route;
    while(~scanf("%d%d",&p,&n))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&machine[i].q);
            for(j=0;j<p;j++)
                scanf("%d",&machine[i].s[j]);
            for(j=0;j<p;j++)
                scanf("%d",&machine[i].d[j]);
        }
        s=0;
        t=2*n+1;
        for(i=0;i<=t;i++)
            for(j=0;j<=t;j++)
                flow[i][j].c=flow[i][j].f=0;
        for(i=1;i<=n;i++)
            flow[i][i+n].c=machine[i].q;
        for(i=1;i<=n;i++)
        {
            int sum=0;
            for(j=0;j<p;j++)
            {
                if(machine[i].s[j]==2)
                    continue;
                sum+=machine[i].s[j];
            }
            if(sum==0)
                flow[s][i].c=INF;
            sum=0;
            for(j=0;j<p;j++)
                sum+=machine[i].d[j];
            if(sum==p)
                flow[i+n][t].c=INF;
        }
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            {
                if(i==j)
                    continue;
                k=0;
                while(k<p&&(machine[i].d[k]==machine[j].s[k]||machine[j].s[k]==2))
                    k++;
                if(k==p)
                    flow[i+n][j].c=INF;
            }
        maxflow=dinic();
        route=0;
        for(i=n+1;i<=t;i++)
            for(j=1;j<=n;j++)
                if(i-n!=j&&flow[i][j].f)
                    route++;
        printf("%d %d\n",maxflow,route);
        for(i=n+1;i<=t;i++)
            for(j=1;j<=n;j++)
                if(j!=i-n&&flow[i][j].f)
                    printf("%d %d %d\n",i-n,j,flow[i][j].f);
    }
    return 0;
}

抱歉!评论已关闭.