现在的位置: 首页 > 综合 > 正文

hdu More is better (并查集)

2013年07月22日 ⁄ 综合 ⁄ 共 1887字 ⁄ 字号 评论关闭

More is better

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 327680/102400K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 6

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

Author

lxlcrystal@TJU

Source

HDU 2007 Programming Contest - Final
并查集水题。
只需用一个rank记录每个节点下面有多少个人,并在合并的时候累加给上一级
需要注意当n==0时,输出为1
#include <stdio.h>

struct Node{
    int pre;
    int rank;
}tree[10000005];
int maxn;

int Find(int x){
    int p = x;
    while(tree[p].pre != p){
        p = tree[p].pre;
    }
    int i = x;
    while(i != p){
        int j = tree[i].pre;
        tree[i].pre = p;
        i = j;
    }
    return p;
}

void Join(int x,int y){
    int fx = Find(x);
    int fy = Find(y);
    if(fx != fy){
        tree[fy].rank += tree[fx].rank;
        if(tree[fy].rank > maxn){
            maxn = tree[fy].rank;
        }
        tree[fx].pre = fy;
    }
}

int main(){
    int n;
    int i,j;
    int x,y;

    while(scanf("%d",&n) != EOF){
        maxn = 1;
        for(i = 0;i < 10000005;i++){
            tree[i].pre = i;
            tree[i].rank = 1;
        }
        for(i = 0;i < n;i++){
            scanf("%d%d",&x,&y);
            Join(x,y);
        }
        printf("%d\n",maxn);
    }
    return 0;
}

抱歉!评论已关闭.